Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: How to translate login form strings generated from Avada shortcode.

Solution: 1) Go to WPML -> Theme and Plugins localization and check the "Translate the theme and plugins using WPML's String Translation" checkbox

2) Scroll down the page to the sections "Strings in the theme/plugins"

3) Choose the Fusion Core Plugins and click the button "Scan the plugins for strings"

4) Once the scanning process is finished, go to WPML -> Strings translation. Search for the strings and translate them in the secondary languages.

Relevant Documentation: https://wpml.org/documentation/getting-started-guide/string-translation/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by henkv-4 5 years, 4 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
April 25, 2016 at 9:36 am #868218

henkv-4

I am trying to:
Translate the User Login shortcode in the Avada theme

URL of (my) website where problem appears:
hidden link

I expected to see:
The English strings in the search results

Instead, I got:
No strings found

Steps to duplicate the issue:

Schermafbeelding 2016-04-25 om 11.35.41.png
April 26, 2016 at 11:09 am #869134

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for contacting WPML support.

#1
Could you please let me know the shortcode that you are using for the login form?

#2
Is the strings/texts shown on the login form is coming from the theme itself or from theme/options?

I look forward to your reply.

Thanks

April 26, 2016 at 11:59 am #869195

henkv-4

Hello Shekhar,

#1
This is the standard Avada shortcode for the login form:
[fusion1_login text_align="fusion_login" heading="" caption="" button_fullwidth="default" form_background_color="" heading_color="" caption_color="" link_color="" redirection_link="" class="" id=""]

#2
The text was already there because I installed a demo from the Avada theme.
I cannot find these texts anywhere in the themeoptions or in the page itself. So I think this text has to be from a .po file.

I hope this helps you to solve my problem.

April 27, 2016 at 4:26 am #869808

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Which version of AVADA are you using? as I only have old version which doesn't accept that login form, I am unable to debug the issue, would you mind providing me the theme file that you are using, so I can debug the issue, you can use google drive or dropbox and send me the link to download it, I have enabled the private reply for you.

I will wait for your feedback.

Thanks

April 29, 2016 at 10:18 am #871914

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

Thank you for the details.

Could you please follow the below steps to translate the strings:
1) Go to WPML->Themes & Plugin localization and check the "Translate the theme and plugins using WPML's String Translation" checkbox

2) Once saved go below the page under "Strings in the theme/plugins"

3) Choose the Fusion Core Plugins and click "Scan the plugins for strings" Button

4) Once the scanning process is finished, go to WPML->Strings translation - Search for the strings and translate them to the secondary languages.
https://wpml.org/documentation/getting-started-guide/string-translation/

Please let me know if the above solution works for you, I look forward to your reply.

Thanks

April 29, 2016 at 12:21 pm #872029

henkv-4

Thank you very much! That solved my issue.