This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Vuk 1 year ago.

Assigned support staff: Vuk.

Author Posts
October 5, 2018 at 9:46 am #2790227

sebastianR-27

Hello, my shop default language is Finnish and i use wpml to tranlate it to englisg. i was able to translate product taxonomies to english but cannot translate word "Hinta" (Means Price in english)

You can see the idea from Here:
hidden link
There unet Price for there is still finnish word Hinta.

October 8, 2018 at 8:54 am #2795205

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

Hi,

Can you please share your site credentials in the boxes provided, so we can assist you.
NOTE: Make sure you do complete site backup before sharing.

Warm regards

October 8, 2018 at 1:21 pm #2796110

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

Can you please check provided credentials. I can't log in. Thanks

October 8, 2018 at 1:43 pm #2796280

sebastianR-27

All the credentials shut be ok. You cannot login to admin or ftp?

October 8, 2018 at 1:45 pm #2796282

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

I can't login to the WP admin panel.

October 8, 2018 at 1:51 pm #2796288

sebastianR-27

Sorry, had a problem with credentials.. Now those same shut work, please try again

October 8, 2018 at 2:48 pm #2796473

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

Great, it is working now. Can you tell me now did you change manually strings in plugin files, since I see that "hinta" is hardcoded in .php template file?

October 8, 2018 at 4:05 pm #2796843

sebastianR-27

Oh ok, then one of developers must have hardcoded it earlier. In what file is it hardcoded?
How to set it correct?

October 9, 2018 at 7:23 am #2798542

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

It should be working if all strings are in English and than translated to the other languages.

Anyway WPML should handle situations like these too. So this can maybe be a bug.
Would you be kind creating Duplicator package so I can forward issue to our development team?

Best regards

October 9, 2018 at 8:30 am #2798907

sebastianR-27

Ok. My site's default language in Finnish and translation neess to be in english. So shut all strings be in finnish instead of english??

What do you mean by duplacator package?

October 9, 2018 at 8:37 am #2798958

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

It looks like a bug, let me forward it to our dev team.

Duplicator is WP plugin which is making copy of your website so we can test and debug it locally.

Here: https://wordpress.org/plugins/duplicator/

October 9, 2018 at 10:44 am #2799533

sebastianR-27

Yes ok, i will send duplicate..

October 9, 2018 at 11:06 am #2799629

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

Thanks.

October 10, 2018 at 5:44 am #2802979

sebastianR-27

Hello, since the shop contain some 7000+ products the site package size is approx 10 GB
SO i think that sending file big like this is not wise... Or do you still want it? Is it mandatory?

October 10, 2018 at 1:53 pm #2804555

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

It is hard to debug it other way. In general different string languages per text domain are not recommended.

1. So for these few Finnish strings I suggest to revert their translations in files to English (or you can translate other 103 strings to Finnish, whatever you prefer)
2. Than I suggest deleting all strings for that text domain from String Translations module
3. Rescan that plugin or theme where the strings are located in WPML > Theme and plugins localization
4. Translate

NOTE: Make sure you empty your cache and disable caching plugins until you try this and get it working.

Best regards

The topic ‘[Closed] Cannot translate Word "Price" in string translations’ is closed to new replies.