Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 2 replies, has 2 voices.

Last updated by patrizio-romanoD 1 year, 7 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
December 17, 2018 at 5:11 pm


I am trying to:

disable any interaction between WPML and multimedia attachments, as I'm getting issues with another plugin and I'm trying to solve

Link to a page where the issue can be seen:
its happening into the admin panel, in WPML > settings > multimedia translation
I can provide full access to a staging copy with the same problem;

I expected to see:
the checkboxes remain unchecked

Instead, I got:
the checkboxes remaining checked

Please note:
I deactivated and purged any cache - W3Total + Cloudflare CDN
I never installed and used WPML Media plugin

December 18, 2018 at 12:14 pm #3012002

Raja Mohammed

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi There,

Sorry for the delay in response. I will help you with your ticket.

The Media Translation settings checked in your screenshot is the default behavior and applies only when you click the start button. WPML recommends those options and hence we have made it selected by default. It won't have any interaction with other plugins.

However, if you have enabled the options under "How to handle media for new content:" section then it may have some interaction with other plugins since the setting applies on each media upload or whenever a translation is created.

I hope this answers your question. if you need any further assistance I will be happy to help you.

Best Regards,

December 19, 2018 at 8:45 am #3015308


Thanks Raja.
It looks like the problem with media duplication was caused by another plugin.
My issue is resolved now. Thank you!