Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Riffaz 1 year, 8 months ago.

Assigned support staff: Riffaz.

Author Posts
August 18, 2020 at 5:44 pm #6825515

delphineF

I am trying to: upgrade from 4.3.16 to 4.3.18

Link to a page where the issue can be seen: the upgrade process fails and falls back to the last known good state

I expected to see: a successful upgrade

Instead, I got:

[Tue Aug 18 17:38:40.153875 2020] [php7:error] [pid 27755] [client 174.7.228.170:35668] PHP Fatal error: Uncaught Error: Class 'Yoast\\WP\\SEO\\Config\\Schema_Types' not found in /nas/content/live/dfn/wp-content/plugins/wordpress-seo-premium/inc/class-wpseo-meta.php:267
Stack trace:
#0 /nas/content/live/dfn/wp-content/plugins/wordpress-seo-premium/wp-seo-main.php(291): WPSEO_Meta::init()
#1 /nas/content/live/dfn/wp-includes/class-wp-hook.php(287): wpseo_init('')
#2 /nas/content/live/dfn/wp-includes/class-wp-hook.php(311): WP_Hook->apply_filters(NULL, Array)
#3 /nas/content/live/dfn/wp-includes/plugin.php(478): WP_Hook->do_action(Array)
#4 /nas/content/live/dfn/wp-settings.php(403): do_action('plugins_loaded')
#5 /nas/content/live/dfn/wp-config.php(122): require_once('/nas/content/li...')
#6 /nas/content/live/dfn/wp-load.php(37): require_once('/nas/content/li...')
#7 /nas/content/live/dfn/wp-admin/admin-ajax.php(22): require_once('/nas/content/li...')
#8 {main}
thrown in /nas/content/live/dfn/wp-content/plugins/wordpress-seo-premium/inc/class-wpseo-meta.php on line 267, referer: hidden link

August 19, 2020 at 4:00 am #6827609

Riffaz

Hi,

Thank you for contacting WPML support.

The error you mentioned comes from 'WordPress SEO Premium' not from WPML.
Please disable or delete that plugin and try to update again. It should work then.

Let me know the results, please.

Regards,
Riffaz.

August 22, 2020 at 1:46 am #6848535

delphineF

Hi!

The update fails on the following 3 plugins:
- WPML Media
- WPML Multilingual CMS
- WPML String Translation

The stack trace I sent is from one of the upgrades, which is why it does not necessarily match up. It doesn't change the fact that none of the upgrades works.

Please help!

Regards,
Delphine

August 23, 2020 at 5:12 am #6852951

Riffaz

Hi,

In this case, please try to update these plugins manually.
This will fix the issue.
How to delete and update plugins manually: hidden link

Let me know the results please.

Regards,

The topic ‘[Closed] Cannot upgrade from 4.3.16 to 4.3.18’ is closed to new replies.