This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Raja Mohammed 1 month, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
August 21, 2019 at 6:38 pm

florianG-22

I am trying to:

Add a page to the translation basket which has the same slug as another page

Link to a page where the issue can be seen:

hidden link

I expected to see:
Page is added to translation basket

Instead, I got:
base 64 error (see uploaded screenshot)
But the error message is misleading.

The issue that is causing this message is described here:
https://wpml.org/forums/topic/unexpected-redirect-caused-by-wpml-not-happening-if-deactivated/

Short explanation of the underlying problem:
I have a page /organisationsentwicklung/
and another one /beratung/organisationsentwicklung/

The patch mentioned by "Bobby" in the support thread indeed does (!) solve the *redirection* issue. So far, so good.

But I still cannot (!) add the page with the slug /organisationsentwicklung/ to the *translation basket*!

Only if I change the slug to a different name/value, the page can be added to translation basket.

So this is a bug in WPML. Is there a fix for this?

(I don't want to rename the slug, because both pages with the same slug are ranking excellently on top positions in Google. )

Thanks for your help.

Best
Florian

August 22, 2019 at 10:15 am #4438323

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with the issue.

Let me try to explain the issue, The page hidden link has some fields in the backend with base64 encoding maybe it is coming from any of the shortcodes in use.

You might need to identify those fields and make them understandable to WPML by adding a custom XML based on the type of field and encoding. please refer to the documentation for more details.

Refernce : https://wpml.org/documentation/support/language-configuration-files/#7f45b

If you can help me identify the encoded fields in your page builder or the shortcodes I can help you further.

Kind regards
Raja

August 22, 2019 at 10:45 am #4438437

florianG-22

Raja, the concept is understood.

BUT:
How do you explain that we can add the page to the translation basket, once we rename the slug?
Please try renaming the /organisationsentwicklung/ post, then add it to translation basket. The error is gone then.

This fact contradicts your assumption. Do you agree?

So I still think the error message has some other root cause.

Can you please help me resolve the issue?

Best
Florian

August 23, 2019 at 4:43 am #4444119

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I have tried with a new slug for the post "Organisationsentwicklung" and got the same result. I am still not able to send the post to the translation basket.

Please refer to the screencast -> hidden link

August 23, 2019 at 1:52 pm #4447865

florianG-22

Hello Raja,

can you please try that again?

I logged in with my credentials, and I can (!) add the same page from the screencast to the translation basket!

So from my point of view, the change of slug makes this possible. No XML error message showing... So this must have to do with the slug, not with XML code missing....

Best
Florian

August 26, 2019 at 6:39 am #4456185

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The issue still persists with the new slug for the page hidden link,

I have tested again by changing the slug and retested with a new slug but still, the post cannot be added to the translation basket due to the base64 encoded fields

Please refer to the detailed screencast: hidden link

Could you please help me with a screencast of the issue you can use the loom hidden link to record the steps.

Kind regards
Raja

August 27, 2019 at 2:50 pm #4467805

florianG-22

I would like to give you my credentials. Please open a private field.

Then you can see yourself...

August 28, 2019 at 6:17 am #4471343

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Private fields enabled for your next reply.

September 2, 2019 at 11:41 am #4496631

florianG-22

I will check with my developers and get back to you.

September 3, 2019 at 3:01 am #4500693

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sure, Thanks for the update