This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.03 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: Elementor is not using the same language as backend language

Solution: I can confirm (checked with the dev department) that this is the expected behavior and the way things work is: due to the fact that Elementor is a front-end editor, it uses the language of the front end, it does not matter what setting you choose in backend, the Elementor panel elements use the same language as the language of the page you are editing.

So what you are setting in backend for back-end language will not take effect in Elemetor FRONT END editor. So this is not simply possible. 🙂

This topic contains 2 replies, has 2 voices.

Last updated by arnoldS-2 3 weeks, 6 days ago.

Assigned support staff: Riffaz.

Author Posts
September 20, 2019 at 12:26 pm #4612033

arnoldS-2

I am trying to edit a Website using Elementor in the English language only.

The website's default language in Hebrew and second language is in English.

The User personal options is set for English and the wordpress backend is working in English apart from Elementor.

I researched the WPML Forum and have tried the following steps;

1. go to WPML String Translation page
2. At the bottom, under Auto register strings for translation, I clicked edit and deselected elementor and elementor pro
3. back at the String Translation page, search for all strings in elementor and elementor pro domains
4. select "display all results"
5. select all strings, click on delete strings

September 22, 2019 at 7:55 am #4617583

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

I can confirm (checked with the dev department) that this is the expected behavior and the way things work is: due to the fact that Elementor is a front-end editor, it uses the language of the front end, it does not matter what setting you choose, the Elementor panel elements use the same language as the language of the page you are editing.

So what you are setting in backend for back-end language will not take effect in Elemetor FRONT END editor.
So this is not simply possible. 🙂

Hope, that explains.

Regards,
Riffaz.

September 22, 2019 at 5:54 pm #4619077

arnoldS-2

My issue is resolved now. Thank you!