This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.33 hours from now. Thank you for your understanding.

This topic contains 6 replies, has 2 voices.

Last updated by Bigul 3 months, 2 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 25, 2019 at 9:12 am #4082545

gaos

we ccannot use translator advanced editor for page's can not translation

June 25, 2019 at 6:24 pm #4086797

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Please try the following steps and let me know you are getting the expected result or not.

1) Visit WPML>>Translation Management>>Translation Roles
2) Set your self as a Translation Manager and Translator
3) Visit WPML>>Settings to refresh the translation settings and make sure *Use WPML's Advanced Translation Editor* option is enabled for *How to translate posts and pages>>New content*
4) Create a new Post or Page
5) Try to translate it

Please check the following documentation for more details.

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/

https://wpml.org/documentation/translating-your-contents/advanced-translation-editor/activating-the-advanced-translation-editor/

--
Thanks!

Bigul

June 27, 2019 at 5:27 am #4096691
gaos

I still can't use the advanced translation editor. And can't translate the main menu of the site.This really makes me feel depressed and anxious

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/split-cant-translate-the-main-menu-of-the-site/

June 27, 2019 at 1:11 pm #4100165

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following steps after a full site backup and let me know your feedback.

1) Login to database using a tool like PHPMyAdmin and run the following query

DELETE FROM wp_options WHERE option_name="WPML_TM_AMS"

(Table prefix may differ in your case)

2) Visit WPML>>Settings to refresh the translation setting
3) Try to translate a Post or Page(which is not translated yet) with Advance Translation Editor.

Please note, I have opened a new ticket for the Menu translation issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. I will get back to you soon on the new ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul

June 27, 2019 at 10:51 pm #4103091

gaos

hello, i have run your query in php myadmin sql, and it's successful.
But i also can not use advanced translate editor
Please help me solve the problem,thanks.

June 28, 2019 at 12:49 pm #4107453

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

July 3, 2019 at 4:58 pm #4138211

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. I have created a test page and was able to translate it via Advanced Translation Editor. Please check the attached image for more details.

Please try the following steps after a backup and make sure you are getting the expected result or not.

1) Visit WPML>>Translation Management>>Translation Jobs
2) Cancel the translation job of *Product* page in both languages
3) Go to Pages>>All Pages
4) Open *Product* page for edit
5) Click on the *+* link of the Language widget(on the right side of the edit screen)

--
Thanks!

Bigul

The topic ‘[Closed] cannot use translator advanced editor for page's can not translation’ is closed to new replies.