This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm trying to make Widget areas translatable, but when I choose "Make 'Widget Areas' translatable", it goes back to "not translatable".

Solution: Please try the following: 1) Go to the widget area in appearance > Widget Areas 2) Select the widget area you wish to display in both languages 3) Turn off the translation editor in that widget area. 4) Change language through the language switcher on the WordPress topbar and then add the page you want that sidebar to be visible on, and save.

This topic contains 5 replies, has 2 voices.

Last updated by Alejandro 5 months ago.

Assigned support staff: Alejandro.

Author Posts
April 29, 2019 at 11:07 am

Светлана Летучая

I am trying to: make Widget areas translatable, but when I choose "Make 'Widget Areas' translatable" on any widget area and click Update, it goes back to "Do not make 'Widget Areas' translatable" automatically. As a result the sidebar widget area does not appear on translated listings (instead post sidebar shows up)

Link to a page where the issue can be seen: hidden link

I expected to see: translated Sidebar widget area on translated lisitings

Instead, I got: post Sidebar

April 29, 2019 at 1:36 pm
April 29, 2019 at 2:48 pm #3704633

Светлана Летучая

Done. Same thing on Sandbox (as on my website), the whole Sidebar widget area doesn´t appear on translated listings. And when I try to mark it as Transltable, it goes back to "Do not make 'Widget Areas' translatable" automatically.
Russian version (Post sidebar appears instead of Listing Sidebar): hidden link
English version (Listing sidebar shows up correctly): hidden link

April 30, 2019 at 9:21 am #3709975

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

The problem is with the plugin called "WooSidebars", so it's not related to your theme or anything about it. i sent this ticket to our developers for further testing and i'll let you know once i get an answer from them.

April 30, 2019 at 9:51 am #3710191

Светлана Летучая

Ok, thank you, Alejandro!

May 2, 2019 at 7:29 am #3722307

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Our team confirmed it's a compatibility issue and they're trying to find a fix. i'll change the status of this ticket to "Escalated to Compatibility Team".

Please don't answer this message (at least not yet).

Just for further information, it's as you mentioned: the sidebar is only loaded in the first language and it's not loaded in the other languages. It's a strange case because it used to work before and the last compatibility code is actually present in the (woosidebar) plugin.

As a workaround i suggest you try an older version of the plugin, because it used to work until december 2018 apparently.

I'll keep you informed on any change.

May 16, 2019 at 8:37 am #3823287

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello,

Please try this workaround:

1) Go to the widget area in appearance > Widget Areas
2) Select the widget area you wish to display in both languages
3) Turn off the translation editor in that widget area (if you can't find a switch like the one on the screenshot attached, please go to the other language because you might be checking out the translation instead of the "original" widget area)

4) Change language through the language switcher on the WordPress topbar and then add the page you want that sidebar to be visible on, and save.

That should do it for now, it looks that the plugin is no longer compatible with our translation editor, so the process has to be done manually (for now, at least).

I tried that on the sandbox site and it worked.