This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Jamal 5 months, 2 weeks ago.

Assigned support staff: Jamal.

Author Posts
April 24, 2019 at 8:10 pm #3676591

tanguyD-4

We wanted to launch an update on the website to introduce /fr on the french version of our pages.
If now it's working see what happen :

We have then two versions of the site as a big duplicate
Every url exist twice as for example :
hidden link
and hidden link

If the canonical was : hidden link on both pages well why not having those two versions but that's not the case...
Each page has it's own canonical !
We can't launch that or we will have major SEO issues.

Can you help us with that ?

Thanks a lot

April 25, 2019 at 9:54 am #3680775

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

I think that you should introduce a root page to your website to get this issue resolved. See more about it in this article.
https://wpml.org/documentation/getting-started-guide/language-setup/directory-default-language/

Can you also paste your WPML Debug information in the Debug information field?
- http://wpml.org/faq/provide-debug-information-faster-support/

Looking forward to you reply.

Best regards,
Jamal
WPML Support

April 26, 2019 at 1:48 pm #3691069

tanguyD-4

Hello Jamal,

I was indeed using a root page on my test.
I just launched it for two minutes to not have any SEO issues.

I hope that with those debug info you can help us.

Thanks a million !

April 26, 2019 at 3:59 pm #3692183

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Indeed it seems from the debug information that you are having home.html as root page, but the settings to use folder for primary language is deactivated (equal to 0).
Can you allow me temporary access to your backend, so i can check this further. Can you also allow me to take a Duplicator snapshot, if needed by our 2nd Tier team or our developers ?

Looking forward to you reply.

Best regards,
Jamal

May 3, 2019 at 10:24 am #3733115

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

As per our support policy, all technical support is provided via our forum, we can't have a call. https://wpml.org/purchase/support-policy/

Regarding the provided access credentials, they are not working. Can you check from your end?

Best regards,
Jamal

May 3, 2019 at 2:47 pm #3735617

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Bonjour,

En effet, une root page était entrée come "home.html" mais le paramètrage "utiliser dossier pour la langue par défaut" n'était pas mis en place. Voir les deux captures.

Je viens de mettre le paramètrage, et je suis redirigé de hidden link à hidden link

Je peux vous proposer de changer la page home.html par une page redirection.php qui contiendra le code suivant:

<?php 
Header("Location: <em><u>hidden link</u></em>");

Comme ça vous n'aurez pas à maintenir une page home.html.

Si jamais je n'ai pas bien comprit votre requête et que ce n'est pas ce que vous désiriez, je vous présente mes excuses pour la modification, et je vous prie d'apporter plus de détails pour y voir plus clair.

Cordialement,
Jamal

May 3, 2019 at 4:24 pm #3736735

tanguyD-4

Thanks a million but that I already figured it out but thanks for the redirection page in php that's much better, so thanks !!!
Anyway no my issue is SEO.

Now it's working but as you will see in the joint file it doesn't do redirection I have two version on the website the one with /fr and the one without it.
This would not be an issue is I had the same canonical, which would be in this case the original one without the /fr but as you will see in the joint pictures I have on each page a different canonical.
This is really bad for our SEO !
Could you help me on that ?? Thanks a lot
Waiting for a solution I went back on what was done because if the robots go on that we could get a penalty.

Thanks !

May 3, 2019 at 4:37 pm #3736927

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

I understand your concern about SEO. But the manipulation I have done should redirect all pages without /fr/ to URLs with /fr/ and in that way you won't have 2 pages let alone 2 canonicals.

I understand that canonicals should point to the original content URL, so even if you have two URLs for the same page( /blog/ and /blog/fr/) they should have the same canonical (either /blog/ or /blog/fr/).

Maybe what you are encountering is an edge case or a bug that was introduced in the latest releases. So, can you tell me what are you trying to do?
- Would you like to have /fr/ URLs? You must activate folder for primary language, to avoid duplicates, you need to enter a root page, this is the settings I configured.
- Would you like to not have /fr/ URLs? This is the current situation, and all traffic to /fr/ URLs is redirected to URLs without /fr/.

Thank you.
Jamal

May 6, 2019 at 4:24 pm #3751131

tanguyD-4

Jamal,

This was my test and what I wanted :

1- Create a root page that I redirect on the home blog page => or just to make as the blog page this way it's looking just the same and it's on the root url so perfect
2 - Launch the WPML action
=> I want to have urls with /fr the thing is that on other website it's working but not on this one !!!
It's driving me crazy I have two versions of the urls but yes I want one only with the /fr/ this way one canonical and game is on but I don't know why if you do the manipulation I still have the old version of the page whereas I just want one, and the one with /fr

I hope I am clear

Clotilde

May 6, 2019 at 4:40 pm #3751205

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello Clotilde,

I think you are clear. You want to have only the /fr URLs. In this case, you'll need to activate a folder for the default language and use a root page(either HTML or a redirect). Then you will be asked to save permalinks. And then you should not have URL without /fr except for the root site URL.

If this is not working on this site, let me check it.

Best regards,
Jamal

The topic ‘[Closed] Canonical Issue’ is closed to new replies.