This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 10 replies, has 3 voices.

Last updated by Raja Mohammed 7 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
February 11, 2019 at 2:52 pm #3183594

carstenB-15

I am trying to: Set up translations for Dutch and German on my page. When I'm setting up the translation pages, the original EN version is getting messed up - mixed German and Dutch urls are replacing the original ones and I can't even access the translated pages. (It shows 500 error).
When I try to deactivate the plugin multiplied images show up in my WP media, showing multiple times the same image with same URL.

Link to a page where the issue can be seen:

I expected to see: The pages I've created and be able to delete them.

Instead, I got: 500 error crushing the website

February 12, 2019 at 11:41 am #3188180

carstenB-15

Hi, can you please advice how to fix the translation problem.
Thanks!

February 12, 2019 at 10:50 pm #3191189

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi there.

Are you using the latest version of WPML and its add-ons?
Today we have released an update to WPML.
If not updated, please update everything and see if the issue persists.

Also please check if your site's installation and server are meeting WPML's minimum requirements. Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/

Could you please share your Debug information with me?
You can read the detailed explanation about it here.
http://wpml.org/faq/provide-debug-information-faster-support
The debug info will give me a lot of information about how your site is configured and will help me understand the source of the problem.

Thanks,
Itamar.

March 11, 2019 at 11:42 am #3310443

carstenB-15

Hi, can you please check and let me know what can be done regarding the issue: "Can't access translated page, messing up the original urls when WPML activated"

March 12, 2019 at 9:39 am #3320257

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for sharing the debug information with me.

Please correct the following and see if it solves the issue on your site.

A. WPML is not updated to its latest version on your site. Please update WPML to its latest version.

B. I can see that Translation Management and String Translation, the add-ons for WPMl are not activated on your site.
Could you please also update those add-ons and activate them ad see if it solves the issue?

C. By looking at the debug info that you have attached I can see that your server WP Memory Limit is set to 40M.
Our recommendations are to have the following as minimal requirements:
- PHP 5.3 and above (this OK with your installation) with a WP Memory Limit of at least 128MB and more if possible.
- MySQL 5.6 and above (this OK with your installation).
Please follow this link for detailed documentation:
https://wpml.org/home/minimum-requirements/
Is it possible for you to change those to the minimum requirement?
You may need to contact your hosting provider for that.
Meeting those baseline requirements is most critical before starting to debug and sometimes solves issues like you experiencing.
Most important is to raise the WP Memory Limit.
Please try to raise it before you contact your hosting company.
You can try and do it from the wp-config.php file in your WordPress installation.
Insert this code in that file.

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Add it before this line:
/* That's all, stop editing! Happy blogging. */

Could you please perform those procedures and see if they help?

Thanks,
Itamar.

March 13, 2019 at 9:16 am #3331125

carstenB-15

Hi,
We've increased the memory limit and installed the Translation Management and String Translation.
I've also clean up everything translated before and started the configuration over.
Now, when I'm setting the languages (EN default and GER second), German is becoming primary language and if try to create a translation to a page it transfers the content. (please see attachments).

P.S. I can send you the debug info but I don't see the option to do it here on this reply.

March 13, 2019 at 7:58 pm #3338007

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Please let me have access to your site and explain to me step by step how to see the issue.

If you need further help with this, please share the access details to your site with me.
I'm enabling a private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

March 19, 2019 at 8:14 pm #3383255

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

Currently, I can see that WPML is not configured on your site. Please see the attached screenshot wpml-not-config.jpg.
Do I need it to be configured that English is the default language and English is the second language?

You wrote: "Now, when I'm setting the languages (EN default and GER second), German is becoming primary language and if try to create a translation to a page it transfers the content."
Where do I see that German is becoming the primary language?
I ask it because by looking at your screenshot it does not look like German is the default language.
Could you please tell me the steps to replicate this issue?

Thanks,
Itamar.

March 19, 2019 at 8:15 pm #3383281

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Just for your information, I've installed the ARI Adminer plugin on your site to check the DB.
https://wordpress.org/plugins/ari-adminer/
I'm waiting for your reply.

Regards,
Itamar.

March 20, 2019 at 10:39 am #3387565

carstenB-15

I'm deactivating the plugin, cause it crashes the website.
It's on now with configuration, please check and let me know
Thanks

March 22, 2019 at 11:21 am #3439753

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

Itamar is off, I'm covering his tickets in his absence I hope that would be okay with you.

I have checked your site and activated WPML temporary, I don't see any issue with it the site is working fine and perfect.

However, What I see is the translations of German and English content is disconnected. As Itamar pointed out English is set as your default language.

You have mentioned that when WPML is active its causing issues and crashing the site, However, I don't see any major issue. I have also created a test post to check the transition its also working fine hidden link and translation stay connected.

Could you please help us with the steps you tried to translate the content, that would be easy for us to reproduce the issue and give you a definite solution.

Kind regards
Raja