This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
January 31, 2019 at 10:54 am #3147358

ericC-32

Hi,

I purchased the basic plan a few days ago, and made a lot of translation for my pages and product(tours). Today I want to further translate other parts of my website, so I upgraded the plan and got the string translation and Translation Management plugins. After installation, error occurred when I activated them. The screen showed "500 Internal Error Occurred". I consult the help desk from WordPress. They told me that the basic part of WPML that I installed is fine, but the two plugs (String Translation & Translation Management) are not compatible with the system. They said that I need to deactivate them or my website will not run. In this case, What can I do? Thanks!

January 31, 2019 at 2:35 pm #3148322

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

There are multiple things that can cause that but we can get a better idea about what is causing that issue by following the steps below.

1. Are there any other errors that you see in the backend? If yes, can you please attach some screenshots?

2. Please follow the steps below:

- disable all plugins except WPML
- check if the issue is happening again by trying to install+activate the 2 WPML add-ons
- if the issue is not happening anymore, please reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know what you will be able to find.

If that doesn't give you any hints while you follow each of the steps, I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

February 1, 2019 at 1:48 pm #3151839

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Sure, I am more happy to help! 🙂

From what I can see, you are also using the Loco Translate plugin. It is not recommended to use multiple translation plugins on the same WordPress site so can you please disable Loco Translate plugin and then try to enable the WPML plugins once again?

Please let me know the results. If you are getting any errors, please save them so that I can see them. You can make a screenshot or something like this.

I will be waiting for your response.

Kind regards,
Mihai

February 1, 2019 at 4:02 pm #3152341

ericC-32

Hi Mihai,

I just tried your suggestion, disable Loco Translate plugin and then enable the WPML Multilingual CMS first, it's fine. After that I enable the WPML String Translation plugins, the same result occurred.

Due to some strings are translated by Loco Translate plugin, in order to maintain the normal working for the website, I enable the Loco Translate plugin again.

What should we do now?

Thanks!

Best Regards
Eric

February 1, 2019 at 6:27 pm #3152920

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Thank you for the update.

Can you please tell me what WordPress support told you when you contacted them?

If you can copy-paste or provide a screenshot, that would be very valuable for me so that I can better understand what is their conclusion.

After I have that, I will spend some more time on debugging and we might even need to migrate this on a server of ours so that we can test for compatibility issues.

I will be waiting for your response.

Just a note that, if you are able to respond in the upcoming days, I will be able to get back to you on Monday as I don't work on the weekends.

Kind regards,
Mihai

February 4, 2019 at 5:02 am #3156302

ericC-32

Hi Mihai,

Please find the attached screenshots for the conservation among wordpress.
Thanks!

Best Regards
Eric

February 4, 2019 at 5:21 pm #3158844

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Eric and thank you very much for the detailed information.

That's really strange to hear as we don't have any known issues related to websites hosted on WordPress.com.

My guess is that there is a compatibility issue that's breaking things somewhere.

Can you please disable all the non-WPML plugins and then try to enable WPML String Translation?

This is a very simple procedure where you just log into your WordPress dashboard > then go to Plugins > and after that you simply check the box next to all the plugins that are not WPML plugins and then deactivate them (hidden link)

After that, try to enable WPML String Translation and see if you are still getting the error.

If you don't, you can activate the plugins you just deactivated, one by one, and you will find the one that's causing the issue.

Please let me know the results.

Kind regards,
Mihai

February 8, 2019 at 8:47 am #3173708

ericC-32

Hi Mihai,

Sorry for my late reply since we just had our Chinese New Year Holidays. Today I just follow your steps to do, but unfortunately, the plugin of WPML String Translation still can't activate and show the message "500 Internal Server Error" Again. I really no idea about this. This is the first time that plugin can't be activated in my site. Hope you have idea and solve for us. Thanks so much!

Best Regards
Eric

February 8, 2019 at 6:50 pm #3176743

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

No worries on the late answer, welcome back!

Can you please try the steps in this ticket below and let me know if it helps?
https://wpml.org/forums/topic/error-500-when-activating-wpml-string-translation/

Just go here (hidden link) and click on each of the buttons in the screenshot I attached.

Let me know if that worked. Also, before trying to install WPML String Translation, please disable all the non-WPML plugins once again (leave only the WPML plugins available).

Please let me know how that goes. I don't work on weekends but if you write me back, I will be able to reply on Monday.

I will be looking for your reply.

Kind regards,
Mihai