Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Can't add admin string to translation

Solution:i went to WPML->Translation Management->Custom XML tab and slightly changed your xml code to the following

Relevant Documentation:

This topic contains 2 replies, has 2 voices.

Last updated by anneL 1 year, 5 months ago.

Assigned support staff: Bobby.

Author Posts
May 29, 2018 at 3:51 am

anneL

I am trying to:

Have a different logo on a language.

I am using Dynamix Theme.
I try to add the string by scanning the theme (not working)
Then by the page "Translate admin screen text" in WPML

Checked the string :
Dynamix_option
-branding_url
--url

But when I applied, I have the confirmation message but after a reload the checkbox is not checked, and the string is still not visible in the string translation page.

I increased my PHP memory to 512M,
Try again with all plugin except WPML desactived
Won't work.

I try manually by adding the file wpml-confil.xml to the root folder of my theme;
<wpml-config>
<admin-texts>
<key name='dynamix_option'>
<key name='branding_url' />
<key name='url />
</key>
</admin-texts>
</wpml-config>

won't work...

Link to a page where the issue can be seen:

hidden link
hidden link

I can provide credidentials. Thanks a lot for your help,
Nathan

May 30, 2018 at 4:11 am #2248909

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

Hi Nathan,

Thank you for providing us with the access details !

i went to WPML->Translation Management->Custom XML tab and slightly changed your xml code to the following

<wpml-config>
    <admin-texts>
        <key name="dynamix_options">
            <key name="branding_url" />
            <key name="*" /></key>
    </admin-texts>
</wpml-config>

this did include the strings to String Translation.

May 30, 2018 at 4:38 am #2248913

anneL

Hello Bobby,
thanks a lot for your quick and reliable help!
Resolved 🙂
Nathan