This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Marcel 6 months, 1 week ago.

Assigned support staff: Marcel.

Author Posts
March 23, 2019 at 12:05 pm #3446237

jesperP-5

I have a total of 4 different languages on my site, English being the default.
Whenever I try to add products to cart in the other languages, it just tells me that it can't add products because there's not enough in stock. This message does not appear when the site is in English and there is plenty of stock.

I have attached a screenshot of the message in Danish.

Can you please assist?

Best regards,
Jesper

March 25, 2019 at 3:13 pm #3455289

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jesper,

Thank you for contacting WPML support.

Can you please try the following Setting: Woocommerce -> Woocommerce Multilingual -> Settings tab -> Troubleshooting link -> Sync all the products.

Does this happen only with newly created products with variations? As we would have a known issue for this.

If the problem still exists, please disable all non-related WPML plugins, switch to one of the default themes and check if the problem persists or not.

Please let me know.

Kind Regards
Marcel

March 25, 2019 at 7:56 pm #3457901

jesperP-5

Hi Marcel,

Thanks for your reply.

I have tried as you advised, but still no change.

I have attached 2 screenshots, first one is from Woocommerce Multilingual settings, where under "Cart", it says "This feature was disabled. Please enable WPML cookies to continue." The second screenshot is when I click on the WPML Cookies-link, it only shows me that - and therefore I don't know where to enable these WPML Cookies?

Best regards,
Jesper

March 26, 2019 at 9:02 am #3460579

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jesper,

thanks for the screenshot, this was helpful:

The function you need to activate is called AJAX cookie:

You will find the option at WPML -> Languages page and scroll down to the Language filtering for AJAX operations section. There, check the Store a language cookie to support language filtering for AJAX option.

More information about this function: https://wpml.org/documentation/getting-started-guide/language-setup/enabling-language-cookie-to-support-ajax-filtering/

Please let me know if this solved your problem.

Kind Regards
Marcel

March 26, 2019 at 11:12 am #3461827

jesperP-5

Hi Marcel,

Thanks for the instructions.

I have activated the AJAX cookie, but it still didn't solve the issue.

Any idea on what else it could be?

Best regards,
Jesper

March 26, 2019 at 11:32 am #3461941

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jesper,

Could I please take a look at your site? For this, I would eventually also need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

Kind Regards
Marcel

April 16, 2019 at 8:54 am #3620115

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Jesper,

I wanted to ask if this issue is still open. If no, could you please mark the ticket as resolved?

Thank you
Best Marcel

The topic ‘[Closed] Can't add products to cart when in other language than default language’ is closed to new replies.