This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 14 replies, has 2 voices.

Last updated by karinaM-4 1 month ago.

Assigned support staff: Bruno Kos.

Author Posts
May 29, 2020 at 12:50 pm #6249969

karinaM-4

I am trying to:I wanted to add a new page and build this with divi. I do this everytime, i build multiple sites with this and your plugin. But since a couple of days the plugin causes me a problem. I am sure it is the WPML Site CMS plugin, because I tested it with all mine plugins.

Further there is a notice on the page that I wanted to change: ActionScheduler op wc_admin_unsnooze_admin_notes

Link to a page where the issue can be seen: hidden link

I expected to see: a normal blank-page to start building

Instead, I got: the wrong message with a sidebar.

June 1, 2020 at 7:31 am #6263505

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Would you be willing to provide me with WordPress credentials so I could investigate the issue directly?

And tell me where and how can I reproduce the issue? So just: "I wanted to add a new page and build this with divi."?

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

I marked your next reply as private so that you can safely add credentials.

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

June 1, 2020 at 8:13 am #6263913

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It looks like that this happens if you save the page as draft first and open in Divi editor, right? If you publish the page and open Divi, it works then and no 404, am I right?

If so, may I ask you to install the latest Divi here?
hidden link

Let me know once you do, let's see if it happens here as well. If yes, then there is maybe some problem with the latest Divi, something I can pass on to our compatibility team. I tested this with 4.4.6 on my localhost, but don't see it happening.

Regards,
Bruno Kos

June 1, 2020 at 8:35 am #6264031

karinaM-4

Hi Bruno,

Yes that is correct. When you publish the page you can go to the divi builder. But if the page is a draft, then you can't go.

I installed the divi theme on that page. Can you let me know what happened?

Best regards,
Karina Marks

June 1, 2020 at 8:47 am #6264083

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It looks like it works on the sandbox site, so unfortunately it is something specific on your site that needs to be checked further.

Can I ask you the following? In order to debug this issue, I will install Duplicator plugin, will create packages and will try this on my localhost and possibly escalate further to 2nd tier.

https://wpml.org/faq/provide-supporters-copy-site/

Let me know if this is OK with you.

Regards,
Bruno Kos

June 1, 2020 at 8:56 am #6264165

karinaM-4

Hi Bruno,

That is ok for me! Will you keep me updated?

June 1, 2020 at 9:27 am #6264349

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Yes, I will keep you updated on how it goes.

The same thing happens in my localhost as well, so let us wait until 2nd tier does a more proper debugging to find out what is behind the scenes here.

Regards,
Bruno Kos

June 2, 2020 at 6:10 am #6270327

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

It seems like this is the reason for it - this happens if you set pages as non translatable and then drafts have no language information, hence triggering 404.

Did you make this change on purpose, or? I reverted it back and now it work.

Regards,
Bruno Kos

June 2, 2020 at 7:47 am #6271249

karinaM-4

Hi Bruno,

I didn't change it as far as I know.

Thank you for putting this back. Now it looks familiar again.

June 2, 2020 at 9:07 am #6272365

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Yes, now it works. In any case the general bug which causes drafts to return 404 is escalated to all developers, but I assume that you want to translate pages, so you can resume working on the site now.

That being said, I believe we can close this ticket, right?

Regards,
Bruno Kos

June 2, 2020 at 1:28 pm #6274593

karinaM-4

Hi,

I still want to say one thing. I made a screenshot to be clear in my story. The pages are connected again. Only one page isn't. I needed to translate it again and later i saw that the french version is in my page overview. But now it stands that that page also need to be translated. Is it possible that I can still change this?

June 3, 2020 at 6:12 am #6279603

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Does this answer it perhaps?
https://wpml.org/forums/topic/change-post-or-page-original-language/#post-1164732

Regards,
Bruno Kos

June 3, 2020 at 12:41 pm #6283661

karinaM-4

Hi,

I made the page to frence, but it is still a seperate page. But I think i will make it again and delete this one. I think that is the fastest way.

If there will be a way in the future. It would be nice.

June 3, 2020 at 1:03 pm #6283925

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

You can do this then, use "Connect with translations" option:
https://wpml.org/faq/how-to-link-already-translated-pages/

Regards,
Bruno Kos

June 6, 2020 at 10:32 am #6310893

karinaM-4

My issue is resolved now. Thank you!