This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 3.45 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:
How to change the currency switcher width?

Solution:

Add this css to WPML > Language > Language Switcher Options > additional CSS

.wcml-dropdown {width: 4.5em;}

Change the value to the amount you want.

This topic contains 6 replies, has 2 voices.

Last updated by alexandreR-23 1 month ago.

Assigned support staff: Riffaz.

Author Posts
September 14, 2019 at 4:52 am

alexandreR-23

I am trying to: change the width. I have tried this https://wpml.org/forums/topic/changing-the-size-of-currency-switcher/ but didn't work for me.

Instead, I got: nothing is happening

September 15, 2019 at 6:31 am #4574021

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

thank you for contacting WPML support.

Do you mean this? hidden link
Could you please give me a URL and a screenshot where I can check this?

Regards,
Riffaz.

September 15, 2019 at 6:11 pm #4575151

alexandreR-23

No, the language switcher, see uploaded image.

Best Regards

September 15, 2019 at 6:15 pm #4575265

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Add this css to WPML > Language > Language Switcher Options > additional CSS

.wcml-dropdown {width: 4.5em;}

Change the value to the amount you want.

Let me know how it goes.

Regards,

September 15, 2019 at 6:20 pm #4575267

alexandreR-23

Doesn't work

September 15, 2019 at 6:25 pm #4575269

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Replace that with this:

.wcml-dropdown {width: 4.5em !important;}

Let me know how it goes, please.

Regards,

September 15, 2019 at 6:45 pm #4575301

alexandreR-23

My issue is resolved now. Thank you!