This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Stéphane 1 year, 3 months ago.

Assigned support staff: Noman.

Author Posts
June 27, 2018 at 5:16 pm

Stéphane

When I try to change the default language to "English" and save the setting, the page refreshes and goes back to "French".

I tried with a generic wp theme with all extensions disabled except WPML, but the problem is still there.

Thanks for helping.

June 28, 2018 at 11:56 am #2440975

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hello Stéphane,

Thank you for contacting WPML Support.

- Please increase MaxInputVars to 10000 or more. For this, please try to set this variables in your php.ini:

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;

You may need to contact your hosting provider to set them.

- Please enable error reporting at you site and let me know if any error found.
To enable it, open your ‘wp-config.php’ file and look for ‘define(‘WP_DEBUG’, false);’. Change it to:

define('WP_DEBUG', true);
define( 'WP_DEBUG_DISPLAY', true );

For more details:
https://wpml.org/documentation/support/debugging-wpml/

=== If still issue persists, please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

June 28, 2018 at 2:09 pm #2441683

Stéphane

Hi Noman,

So I did all you indicated, but the problem persists.

By the way, I see the same problem if you go to:
Woocommerce -> Settings -> Email -> Open the first email and try to change for exemple the language of the subject. You'll see it doesn't change. I guess it is the same source of the problem.

Also, you can do what you want with this website, this is a copy for your investigation.

Thanks.

June 28, 2018 at 3:01 pm #2441962

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stéphane,

I can not see wp-admin login screen due to errors that mostly coming from your theme and child theme as you can see in attached screenshot. Can you please activate default(twenty seventeen) wordpress theme and see if it resolve errors.

FTP login info that you have provided is not working here as you can see in attached screenshot. Could you please provide me working login please. I have enabled private input box for your next reply.

Thank you

June 28, 2018 at 3:40 pm
June 28, 2018 at 5:08 pm #2442356

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stéphane,

FTP login info still not working. I have activated default theme and deactivated all the plugins that are not related to WPML but issue still there. Then I install File Manager plugin to enable error reporting to see errors that causing this issue but this plugin not showing it’s menu due to some issue in your installation.

Can you please provide me working FTP please, so that I can debug it further.

Thank you

June 28, 2018 at 6:20 pm
June 29, 2018 at 9:26 am #2444504

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stéphane,

I have thoroughly debugged your site and this issue and finally I have found out that ‘SG Optimizer’ plugin causing this issue.

I have fixed this by disabling memcache option from ‘SG Optimizer’ plugin. Now WPML working as expected. Can you please check and confirm?

P.S. Your theme is still throwing errors when we enable error reporting as you can see in attached screenshot. I recommend you to please fix those errors to avoid inconvenience in future.

Thank you

June 29, 2018 at 12:17 pm #2445625

Stéphane

HI Noman,

Great, that works for the default language.

But there is still an issue. If you go to:

Woocommerce -> Settings -> Email -> Open the first email and try to change for example the language of the subject. You'll see it still doesn't change.

For your information, I've update all Woocommerce templates to be sure that it was not the source of the problem.

Thanks for keeping on looking.

June 29, 2018 at 12:36 pm #2445731

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi Stéphane,

As your default language issue is got resolved. Can you please open a new ticket for each issue and we would be happy to help. This will help other users with similar problems to find solutions when searching the forum, We do not handle multiple issues in one same ticket as per support policy.
https://wpml.org/purchase/support-policy/

Thank you

July 7, 2018 at 2:43 pm #2472577

Stéphane

Thanks