This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 1 year, 5 months ago.

Assigned support staff: Bigul.

Author Posts
May 16, 2018 at 5:01 pm

riteshP

I am trying to: change the english flag to US flag (custom)

Link to a page where the issue can be seen:I disabled the language switcher on the main menu. I can't have it displayed as the english flag.

I expected to see: I need it to save the US flag as the custom one for english hidden link

Instead, I got:When I use the custom flag and save the changes it returns a blank screen. hidden link

May 18, 2018 at 10:12 am #2188706

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues. Sorry for the delay in response due to the large volume of support requests.

Please share me the Custom Flag image you are trying to upload for the English language. So I can try it on my local copy.

Please add the following code in wp-config.php file of your site to enable WordPress to debug mode. It will create a *debug.log* file in *wp-content* folder and the PHP errors, warnings, & notices will be stored in this file. Then please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );
 
// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

Please check following links to read more about debugging with WordPress.

https://codex.wordpress.org/Debugging_in_WordPress

https://codex.wordpress.org/Debugging_in_WordPress#Example_wp-config.php_for_Debugging

--
Thanks!

Bigul

May 18, 2018 at 4:35 pm #2190727

riteshP

Attached is the flag I'm trying to use as the custom flag.

I've also added the code to wp-config.php and have replicated the error but I still don't see any debug.log.

May 18, 2018 at 6:59 pm #2191438

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and flag image. I can reproduce the issue on your site. But it works as expected on my testing site. Please check the attached images.

It may be happening because of compatibility issues with other plugins/the theme or your server. So as a workaround for the time being, please do the following steps after a backup.

1) Please login to your FTP
2) Go to *wp-content/plugins/sitepress-multilingual-cms/res/flags/
3) Resize your flag file, the recommended size is 18*12 px
4) Upload your custom flag to the *flag* directory
5) Rename the current English flag to *enOLD.png* from *en.png*
6) Then change your custom flag's name to *en.png*
7) Clear all types of caches and check you are getting the expected result or not

--
Thanks!

Bigul