Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I was able to locate the header image in the theme, but when I try to check the box & hit Save button at the very bottom I get this error message : Error, data not saved.

Solution: You can add the admin text string using a language configuration file.

Relevant Documentation: https://wpml.org/documentation/support/language-configuration-files/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Otto 4 years, 11 months ago.

Assigned support staff: Otto.

Author Posts
August 22, 2016 at 12:00 am #1012674

jonathanF-3

I am trying to change the logo on the english version of my website + some placeholder text in a ninja form. (Original is french)

URL of (my) website where problem appears: Will provide the URL via private reply

What I already tried :
- Scan the theme for string (couldn't find the image header logo in these string)
- Translate texts in admin screens : I was able to locate the header image in the theme, but when I try to check the box & hit the save button at the very bottom I get this error message : Error, data not saved. To solve that, I've added this to my php.ini file but that didnt' solved the issue :

max_input_vars = 10000;
suhosin.post.max_vars = 10000;
suhosin.request.max_vars = 10000;
_____

Regarding the placeholder text in the form (and the "SUBMIT" button) I wasnt able to find them in the string, so not able to translate.

August 22, 2016 at 12:10 pm #1013784

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

Please apologise for the delay in answering. This is not usual in this forum. I'll take care of your ticket and reply time will be shorter from now.

Can you please check you phpinfo so we can be sure that the "max_input_vars" that you defined is taking effect? To do it, please follow this steps:
https://wpml.org/home/minimum-requirements/
"How to check which version of PHP you’re actually using"

If it does, please increase the value to 30000.

Let me know your results, please.

Regarding the form issue, if I'm not mistaken it is added as a widget, right?

If so, you may want to take a look at this workaround:
https://wpml.org/2014/08/display-different-widgets-per-language-wpml-widgets/

Let me know if it worked and if it's a suitable solution for you.

Kind Regards,

Otto

August 22, 2016 at 12:31 pm #1013816

jonathanF-3

Header image :
max_input_vars is at 30000 and it's not working.
Php 5.6 on the server

Contact form :
The widget is "genesis news e-news extended" -> Should I normally be able to translate using string ?

August 22, 2016 at 2:44 pm #1014225

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks!

Can I take a look at the phpinfo page? I'll set next reply as private so you can share it safely.

The widgets are translated as you said in WPML > String Translation. But sometimes, due to compatibility issues it does not work well. So, as a workaround there is the plugin that I mentioned. Did you try it? Didn't work or it is not a suitable solution for you?

Kind Regards,

Otto

August 22, 2016 at 4:24 pm #1014396

jonathanF-3

Ok I have access to phpinfo now from my host. Please allow a private reply

August 22, 2016 at 7:09 pm #1014700

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks.

I set a private reply again. There is no need for the DB for now.

Kind Regards,

Otto

August 22, 2016 at 9:03 pm #1014851

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you.

In order to add the header_image you may use a language configuration file:
https://wpml.org/documentation/support/language-configuration-files/

This may be tricky, so if you prefer I can do it for you.

To do so I would like to request temporary access via FTP to your site to take a better look at the issue and I may need to install the Adminer plugin.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Kind Regards,

Otto

August 23, 2016 at 11:54 am #1016152

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks for the credentials.

Please do the following:
-Add a file named wpml-config.xml in the root of your theme's folder with the following content:

<wpml-config>
  <admin-texts>
    <key name="theme_mods_showcase-pro">
      <key name="header_image"/>
      <key name="header_image_data"/>
    </key>
    <key name="gse-settings">
      <key name="post_info"/>
      <key name="post_meta"/>
      <key name="footer_creds_text"/>
      <key name="footer_output_on"/>
      <key name="footer_output"/>
    </key>
  </admin-texts>
</wpml-config>

-Scan the theme:
1. Go under “WPML -> Theme and plugins localization”
2. Make sure that “Translate the theme and plugins using WPML's String Translation” is active
3. Scroll down to “Strings in the theme” and click on “Scan the theme for strings”
4. Scroll down to “Strings in the plugins”, select the plugin Genesis edits and click on “Scan the selected plugins for strings”
-After that in WPML > String Translation you will find the image link to "translate" and also the shortcode string

Let me know if this worked for you.

Otto

August 23, 2016 at 3:40 pm #1017177

jonathanF-3

Hi ! Problem solved. Just wondering for the future, if working on a different project : How is it possible to know if we need to use a wpml-config.xml file ?

August 23, 2016 at 6:41 pm #1017771

Otto
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I'm glad it helped.

Usually, you should be able to add those strings via the Text of admin screens page. In this case, we use the language configuration file as a workaround.

This file is used to preconfigure some WPML setup options.
https://wpml.org/documentation/support/language-configuration-files/

Kind Regards,

Otto