This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 4 replies, has 2 voices.

Last updated by George Botsev 1 year, 3 months ago.

Assigned support staff: George Botsev.

Author Posts
July 3, 2018 at 4:39 pm

Stéphane

Hi,

I've got some fields that are stucked in french language. If I change the flag language to English, I save it and it goes back to French.

You can see the problem if you go in the admin there:

Woocommerce -> Settings -> Email -> Open the first email and try to change for example the language of the subject. You'll see it still doesn't change.

For your information, I've update all Woocommerce templates to be sure that it was not the source of the problem.

July 5, 2018 at 7:10 am #2465899

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

Hello and thank you for contacting us.
As far as I know, we just pushed a fix for exactly the same thing in WooCommerce Multilingual 4.3.3
However, as a workaround you can change these strings language from WPML > String Translation - just search for the appropriate string and change its language.
From there it should work.

July 5, 2018 at 7:18 am #2465914

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I just tested this in a clean local test environment with our latest versions and I cannot reproduce the same problem - for me the language is changed from that screen.
Perhaps you should check and enable debug logging in WordPress and see if there is an issue there.
Also check if the suggested method from above works - changing the language from String Translation should always work.

July 5, 2018 at 2:02 pm #2467693

Stéphane

Hi George,

That's right, the 4.3.3 update fixed the problem. Thanks !

July 5, 2018 at 2:05 pm #2467716

George Botsev
Supporter

Languages: English (English )

Timezone: Europe/Sofia (GMT+03:00)

I am very happy to hear that.
Thank you for getting back to me and confirming.

Have a wonderful day!