This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 3 voices.

Last updated by Laura 6 months, 2 weeks ago.

Assigned support staff: Laura.

Author Posts
March 27, 2019 at 10:12 am

hamidT-3

I am trying to:
I find another issue about copying content from english version of website. when I try copy any English versian of website to persian language, it can't copy
when I try to copy of english versian of Homepage hidden link to persian hidden link It can't .
Link to a page where the issue can be seen:
It just copy the url of english page
I expected to see:

Instead, I got:

March 27, 2019 at 4:18 pm #3473605

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

1. Can you please create a full backup of the current site and then go here (hidden link) and update the current theme to the latest version?

2. Can you please tell me step by step how did you try to copy the content from English to Persian?

3. Can you please send me a screenshot of the exact content parts that did not copy - the ones that you are referring to above?

Please let me know.

I will be waiting for your reply.

Kind regards,
Mihai Apetrei

March 31, 2019 at 12:23 pm #3501945

hamidT-3

1. I have updated WP Engine already

2. I go to home page of English version (or any page) / click on edit page /then when I in the backend I click on drop-down Persian Flag from top / the flag take me to persian language of website / I click on button called : COPY CONTENT FROM ENGLISH , but just title of page and url of page is being copied by WPML

3. I content I have created by Muffin builder is not copying by WPML

April 1, 2019 at 7:17 pm #3511189

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the information.

I tried to log into the backend of your site but it is not working anymore.

Can you please check and let me know?

I will enable the private fields once again.

In order to be able to help you faster, can you also please paste your WPML Debug information in the Debug information field?
http://wpml.org/faq/provide-debug-information-faster-support/

I will be waiting for your response.

Kind regards,
Mihai

April 3, 2019 at 12:45 pm
April 3, 2019 at 4:46 pm #3528897

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that they worked this time.

Debug information also looks just fine.

I got in touch with some of my colleagues and they told me that Muffin Builder is not fully compatible with WPML yet.

However, there is an existing workaround for the moment. Please follow the steps my colleague recommended here: https://wpml.org/forums/topic/muffin-builder-wpml-translation/#post-2873140

Here are also some other tickets related to Muffin Builder issues where the same solution is recommended:
- https://wpml.org/forums/topic/be-theme-and-muffin-builder/
- https://wpml.org/forums/topic/betheme-muffin-builder-and-translation-management-compatibility/

That should make things work for the moment until this builder becomes fully-WPML-compatible.

Please let me know if this solved your issue or if you still need help. 🙂

I will be waiting for your response.

Kind regards,
Mihai

April 8, 2019 at 9:24 am #3555955

hamidT-3

Dear Mihai,

your steps guide is not even available.
1. in the WPML /section there is no option for manual translation
2. There is no manual translation mode in single page.

the steps are explained are not available.

April 8, 2019 at 11:06 am #3556979

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

Mihai is currently off so I'll continue here if this okay for you.

About steps not available, if you are referring to steps 1 and 2 from this guide: https://wpml.org/documentation/translating-your-contents/using-different-translation-editors-for-different-pages/
you don't see the option in WPML -> Setting because you don't have Translation Management active on your site. Without this plugin, the only possible option is manual translation. However, without Translation Management is not possible to translate page builders modules so probably this explains why when you duplicate pages you don't get them.

Could you please activate Translation Management and see if the page builder modules are correctly copied over?