Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bigul 2 years, 8 months ago.

Assigned support staff: Bigul.

Author Posts
December 5, 2017 at 8:07 pm

mohamedl

I am trying to: update currency rates

Link to a page where the issue can be seen: multi currency settings page

I expected to see: currency change rate

Instead, I got: nothing and even deleting the currency dont work

December 7, 2017 at 9:07 am #1451548

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @mohamedl,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Are you having the issue only with *Moroccan dirham* or with *Euro* also? Does it work as expected when *Enable automatic exchange rates* feature is disabled.

I have added a new currency(AED) and delete it. Please check the attached images. So please let me know the exact steps to reproduce the issue(cant delete a currency).

If you are still having the issues, please share with me the WordPress debug.log (not WPML debug information). Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

December 7, 2017 at 10:43 am #1451704

mohamedl

hi

thanks but like I said, its not just the deleting part event that works now, but the exchange rate doesn't change at all when I add a new currency, it remains at 1=1 specially for the moroccan dirham, I update the rates its works only for euro but no other currency

thanks

December 7, 2017 at 3:51 pm #1452076

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @mohamedl,

Thank you for the updates. Maybe you are facing this issue because of compatibility issues. So to make sure it if possible, please do the following steps.

a) Backup your site first
b) Switch for a moment to a WordPress default theme like 2017
c) Deactivate all the plugins that are not related to WPML
d) If the issue is gone, activate one by one to see with which one there is an interaction issue

Also please check you are getting any error related to WPML in *debug.log* file when *WordPress Debug mode* is on.

--
Thanks!

Bigul

December 7, 2017 at 8:40 pm #1452392

mohamedl

hi

id id that already and it didn't work, I did it again and it was working before without issues,

so if you cantata a look that could be really good

thanks

December 8, 2017 at 3:42 pm #1453029

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @mohamedl,

For your kind information, we can't edit the Currency rate manually when *Automatic Exchange Rates* option is active. That is why now you can't set manual currency rate for *Moroccan dirham*.

About the problem with automatic conversion, unfortunately, the Yahoo service seems to have been discontinued and Fixer.io will not support *Moroccan dirham*. So it will not convert to *MAD* from *USD*. Please check the following links for more details.

hidden link && hidden link

So as a workaround you can try the following options.

1) Use *currencylayer* API for the *Automatic Exchange rates*. Please check this link -- hidden link, it will support *Moroccan dirham*.

2) Or disable *Automatic Exchange Rates* option

Please try it after a site backup and let me know your feedback.

--
Thanks!

Bigul

The topic ‘[Closed] can't delete a currency and updating rates dont work’ is closed to new replies.