If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 27 replies, has 3 voices.

Last updated by jamesB-17 7 months, 1 week ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
March 13, 2019 at 2:54 pm #3335167

jamesB-17

I am trying to: Delete jobs/ see any in progress

I expected to see: a list of translation jobs and their progress with an option to delete the translation job

Instead, I got: A list of previously completed jobs that needs updating but no way of deleting them or sending them to the external agency to translate. I also notice that before I translate the page it says that there is a translation in progress but I can't delete any of the translation jobs that I see since they are not 'local'. We have contacted SDL, the translation company, and on there end it says it's all complete so they can't delete them on their end. We did wonder as some of the pages say that there is an update needed that if the English page had been updated and was included in the batch that had been sent to SDL it would forever stay on update needed unless it was sent to them again. However, after this batch, we did realise that the way both systems work they were incompatible. Is it possible for you to delete these to see if that solves the issue because it works perfectly fine if you create a new page and then translate that into a new language. This mainly happens with pages when translating into Dutch. As you can see it says add translation to Thai rather than it's alternative.

Thanks in advance

March 14, 2019 at 11:00 am #3343259

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

Thank you for contacting WPML support!

Were these translations marked as "complete" at one point?

When you say:

We did wonder as some of the pages say that there is an update needed that if the English page had been updated and was included in the batch that had been sent to SDL it would forever stay on update needed unless it was sent to them again.

Yes, that would be an expected behavior. If you made any change to original content, they would shift from "Completed" to "Needs update".

However, in your scenario:
- you received all the translations already?
- these are visible in the frontend?

You could, howerver, try with:
WPML -> Support -> Troubleshooting -> Reset professional translation state

However, this should be used only as a last resort, but if you will not be sending translations back to them any more, it would work.

"Use this feature when you want to reset your translation process. All your existing translations will remain unchanged. Any translation work that is currently in progress will be stopped. Only select this option if you have no pending jobs or you are sure of what you are doing."

Also, do you have an option to click "Edit" when on Translations tab, where does it take you (if it is there)?

Regards,
Bruno Kos

March 14, 2019 at 2:13 pm #3345301

jamesB-17

Hi Bruno,

I will answer your questions before doing your suggestion of WPML -> Support -> Troubleshooting -> Reset professional translation state

- you received all the translations already? Yes we have
- these are visible in the frontend? No these are not visible, just says they're in progress when trying to translate the individual pages.

Also, do you have an option to click "Edit" when on Translations tab, where does it take you (if it is there)? There is an option and it takes me to see screenshot attached. I notice it says 60% complete at the bottom but I can also not see all of the pages that are being classed as 'in progress/ needs update' in the list

I will await your reply before resetting the professional translation state.

Thanks for your help on this

March 14, 2019 at 2:29 pm #3345583

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

March 15, 2019 at 11:06 am #3353335

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

I've asked our 2nd tier for an opinion and I will get back to you as soon I will have more information.

Regards,
Bruno Kos

March 15, 2019 at 1:28 pm #3354291

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+01:00)

Hi,

This has been escalated to 2nd tier and will take some debugging time, I'll get back to you as soon as I have any news or questions for you.

Regards,
Bruno Kos

March 15, 2019 at 2:50 pm #3354809

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, this is Ahmed Ibrahim from the 2nd tier support team.

I have checked the status of these jobs, and as I can see you haven't received all of the translations, some of them still in progress at your site, and I think you haven't received these translations because you have deactivated the translation service already.

So if you want to receive the rest of the jobs, you have to activate the translation service again with the same authentication key, and then we will try to download the rest of the translations.

If you don't want to receive these translations and you want to edit or send these jobs again, you can simply go to WPML -> Translation Management, and then send them to the translation service again or to a local translator, and the old job will be cancelled automatically when creating the new one.

Please let me know if that helps you.
Best Regards.

March 18, 2019 at 8:54 am #3366963

jamesB-17

Hi Ahmed

I can't see the ones that had been originally sent to the translators so I can only see pages created since or ones that have come back therefore not being able to send them to a translator which may, in turn, fix this problem.

So I will get the translator plugin reinstated to see if they can be downloaded so that it gets marked as complete on both systems, not just the one.

I will let you know when I have further updates.

Thanks

March 18, 2019 at 12:54 pm #3369561

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

can you please elaborate more about this:
"I can't see the ones that had been originally sent to the translators"

From what I understand that you have some posts at your system and you can't see them at the WPML -> Translation Management table, is that true?
if yes, please send me a link to one of these posts and I will check them.

Best Regards.
Does these pages still exist at youe site, can you please send me the link

March 18, 2019 at 1:39 pm #3369795

jamesB-17

Hi Ahmed,

Sorry, my fault, it turns out that they were there I just never looked hard enough. However, when following your steps and sending it to a different translation manager it goes in the WPML translation editor. Is there a way of not using this and making it the same as the rest of the site? so when editing a translation it's displayed in widgets rather than text?

Thanks

March 18, 2019 at 2:31 pm #3370259

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Glad that you can find them now.

Please let me know if you want to translate these jobs locally or you want to use any translation service. If you will translate locally, so the best option will be to use the Translation Editor, but if you want to send them to Translation Service, you have to go to WPML -> Translation management -> Translation Service, and activate the service that you want to use, then send the pages to it
More info here: https://wpml.org/documentation/translating-your-contents/professional-translation-via-wpml/

Please let me know if that helps you, and if you still have any issues, please elaborate more about your issues, and also attach some screenshots to help me understand it better.

Best Regards.

March 18, 2019 at 3:33 pm #3370881

jamesB-17

Hi Ahmed,

This had seemed to work I now get add a translation to dutch when hovering over the translate button.

However, now when I use that button it continues to do what I expect so I then click overwrite with English content but then it doesn't go into page builder just in the text field.

See screenshots attached of the steps I've taken to get there.

I would expect the page to dupe across in the page builder rather than text. One of the screenshots also shows you that panel data is set to duplicate, I thought this was for the page builder aspect, could be wrong.

Kind regards

March 18, 2019 at 5:17 pm #3371797

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I'm not sure why you want to use the normal editor to translate these pages, the best option to translate pages that have been created using a page builder module is to use the Translation Editor, so if you will translate this locally, I recommend you to go to WPML -> Settings and use the Translation Editor for this.

Best Regards.

March 19, 2019 at 9:19 am #3377001

jamesB-17

Hi Ahmed,

Sadly, we have to use the normal editor for this as we use widgets and when we don't the styling of the pages go so the page doesn't look correct. I've attached a screenshot of the view it should be when in page builder mode.

Thanks

March 19, 2019 at 6:00 pm #3382267

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

Ok, so can you please try to duplicate it first to the second language, then go to the duplicated page, and then click on translate independently and then change the content as you want.
More info about how to duplicate: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Please let me know if that helps you.
Best Regards.