This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 6 replies, has 2 voices.

Last updated by Bruno Kos 1 month, 1 week ago.

Assigned support staff: Bruno Kos.

Author Posts
May 23, 2020 at 8:07 pm #6202189

nataliaM-3

Dear support, hope you are doing well. Kindly give me some minutes to figure out issue.

Im trying to edit main page (Russian) but get troubleshooting (pic.1). However I can edit English version of main page.

Im talking about yanchenwuguan.com but already can give you access to stage1.yanchenwuguan.com bottom.

Main Language is English, second language is Russian (folder /ru/), however mostly all the pages was created in Russian language (pic.2) and had translated to English. So i think my issue related to mentioned fact.

- How to edit main page?
- May I reassign original and daugter language?

May 25, 2020 at 1:02 pm #6210421

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me at which point does the issue from your images appear?

Regards,
Bruno Kos

May 27, 2020 at 8:46 pm #6232963

nataliaM-3

Thank you for assistance.

Since question was rises I have solve that issue from "troubleshooting" fix buttons. However I feel that translating workflow was affected. So still have difficulties

Firstly kindly give response according order of translation: site language is English. Job No 260 (from topicstarted pic 2020-05-23_22-21-28.jpg) Created in Russian and then translated in to English, this order will work correctly in all cases?

Secondly I edited the main page in Russian
hidden link

If im try to translate this page, in to English the translation shows as 100% complete, but this is not the case. (pic. 2020-05-27_23-13-24.jpg) and (pic. 2020-05-27_23-12-59.jpg)

Another example:
please see (pic. 2020-05-27_23-37-46.jpg)

Thank you in advance

Alex

May 28, 2020 at 5:45 am #6235725

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Created in Russian and then translated in to English, this order will work correctly in all cases?

Yes, why not. The order in which something is created and then translated doesn't matter.

As for the other issue, these are regular heading elements so not sure why these didn't show up there, but I only updated the original page and they are within ATE now.

Regards,
Bruno Kos

May 29, 2020 at 5:56 pm #6252049

nataliaM-3

Hi,

Right before send that message I was updated post in Elementor. I'm sorry to bother youю How did you do the update? From back in Gutenberg?

May 30, 2020 at 10:38 pm #6257397

nataliaM-3

May be my issue related to changing between wordpress translation mode and advanced translating mode (screenshot). Feels like need reassociation or something like that.

I try to make a new post and get "Publishing failed" (screenshot)

Already deactivated all plugins as mentioned here: https://wpml.org/forums/topic/publishing-failed-on-blogs-and-pages/ (screenshot)

Best,
Alex

June 1, 2020 at 5:44 am #6262949

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced.

1. Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true);
define( 'WP_DEBUG_DISPLAY', false );

2. Reproduce the issue - by this I mean try saving or creating a new post, and also try synchronizing or activating advanced translation editor, where also it hits fatal error as you pointed out in one of your images.

3. Locate the debug log in: /wp-content/debug.log

4. Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

https://codex.wordpress.org/Debugging_in_WordPress

Regards,
Bruno Kos

The topic ‘[Closed] Can't edit page of original language’ is closed to new replies.