Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 2 voices.

Last updated by rufusB 2 years, 1 month ago.

Assigned support staff: Itamar.

Author Posts
November 3, 2018 at 6:05 pm #2874008

rufusB

I am trying to: update exchange rates automatically and edit default currency

Instead, I got: The exchange rates were stuck in 2017 according to the manual updater and are still stick in June 2018 according to the auto updater. I've tried using fixerio and currencylayer APIs but neither will work. I was able to update manually.

November 5, 2018 at 9:06 pm #2878468

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Are you using the free or paid API from fixerio or currencylayer?
It is not clear to me.
If you press the 'Update manually now' button, does the currency get updated to the current date and time?

Regards,
Itamar.

November 5, 2018 at 9:16 pm #2878491

rufusB

Hi Itamar,
I'm using the free API's and the date and time are not updated manually. Updating from the currencies display is erratic but possible. Often the update doesn't save. Likewise, I am unable to change the default currencies from this interface or currencies to display. When I save the changes they revert to old values.

November 5, 2018 at 9:25 pm #2878509

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

OK, thanks for the extra information.

I suspect that there is a collision with the theme or another plugin.
If possible get your site into a minimum environment.
Minimum environment means switching to a default WordPress theme like Twentyseventeen and no plugins activated but WPML.
Is it possible for you to try it?
You will need first to check if the problem persists when just the theme is switched to Twentyseventeen (for example).
If it persists, then deactivate all plugins except WPML and its add-ons and WooCommerce itself but without any of its extensions.
Then please check if the problem persists.
If it does not persists so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Does the problem persist in a minimum environment?

Regards,
Itamar.

November 7, 2018 at 12:32 pm #2885204

rufusB

Hi Itamar, I tested in twenty seventeen as you suggested, including with all but WPML and woocommerce plugins deactivated and caches flushed. Unfortunately the problems persist.

November 7, 2018 at 9:26 pm #2887145

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for trying my suggestions.

If the minimum environment procedure did not point to the problematic plugin or theme, please do the following:
Please provide me with the WordPress debug.log
Please check this page for instructions.
https://wpml.org/documentation/support/debugging-wpml/
Look under the headline "Enabling the built-in debugging feature in WordPress".
To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);.

Change it to:

define('WP_DEBUG', true);
// Enable Debug logging to the /wp-content/debug.log file
define('WP_DEBUG_LOG', true);
// Disable display of errors and warnings which is recommened on a live site.
define('WP_DEBUG_DISPLAY', false);
@ini_set('display_errors',0);
define( 'WP_DEBUG_LOG', true );

Then please press the 'Update manually now' button and check the debug.log

In this case, the log will be saved to a debug.log log file inside the /wp-content/directory.
If you can paste your debug.log to pastebin.com and provide me that link, it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in the discussion).

Please, could you provide me the additional Info?

Thanks,
Itamar.

November 7, 2018 at 10:15 pm #2887188

rufusB

Hi, that didn't go so well. I tried twice and it crashed the site, giving a syntax error message. I was unable to undo the edit and had to replace the entire file. Can I upload the file for you to take a look at?

November 8, 2018 at 4:50 pm #2890194

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and sorry that that didn't go well.

Do you mean that you want to send me the wp-config.php file?
Maybe it would be better if you give me access to your site and I'll check things on your site.

If you need further help with this, please share the access details to your site with me.
I'm enabling private message for the next reply.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- - Please make a backup of site files and database before providing us access. --

Thanks,
Itamar.

November 8, 2018 at 8:34 pm #2890932

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for the access details.

I'll check the issue and be able to reply on Sunday.

Thank you for your patience.
Itamar.

November 11, 2018 at 10:33 am #2896445

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for the access details.

I'm glad that you can now manually update the exchange rate from GPD to USD.

About the following issues.
1. No auto exchange update.
2. No manual update or date change from Automatic Exchange Rates.
I've checked things on your site and in WooCommerce -> WooCommerce Multilingual -> Multi-currency -> Automatic Exchange Rates, I can see the following message.

WARNING! Minor limitations include 1000 requests/month limit and EUR being the only available base currency for customers using a free account. If you need more than 1000 requests per month or want to use all 170 available base currencies, you’ll need to choose one of the paid plans starting at only $10 per month.

Please see the attached screenshot fixer-warning.jpg
This explains why there is no automatic update and you cannot manually update the Automatic Exchange Rates. You are using the free service, and in this case, EUR must be the default currency, and on your site, GPD is set as the default currency.

Please let me know if it clear now?

About the 'can't change default currency' issue.
The default currency can be changed from WooCommerce -> Settings -> General -> Currency options. Please see the attached screenshot default-currency.jpg.
Is this where you are trying to change the currency?
FYI, this is WooCommerce settings and not WooCommerce Multilingual settings.

I look forward to your reply!

Itamar.

November 11, 2018 at 2:32 pm #2896545

rufusB

Hi Itamar,

thanks for that, which clears up the automatic exchange rate update part of the problem.

However, I was also referring to my attempts to update the Currencies interface ABOVE Automatic Exchange Rates. As you will know, I have three currencies in use, with two options for each language (I was unable to make all three currencies available in both languages, see below). After temporarily changing default currency to Euros to test updating exchange rates manually, which worked, I found when I reverted to GBP as base currency that euros has disappeared completely and, although listed as default currency, GBP could not be checked and saved in the English language switcher, resulting in all prices in USD. See attached.

The settings in this interface are only intermittently editable, I have never understood why one day they save, the next they don't. As today they don't save, I had to restore a backup to regain Euros and GBP. This is the outstanding problem.

Cheers,

Rufus

November 12, 2018 at 12:48 pm #2898499

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi, Rufus.

I'm glad that the Automatic Exchange Rates issue is solved now.
As for the currency saving issue, currently when I look at your site it looks like you were able to add the Euro currency and now you have three currencies, and GBP is the default currency. Please see the attached screenshot.

Are you still having issues saving changes in the multi-currency section?
If so, then please tell how to see the issue on your site.

Thanks,
Itamar.

November 12, 2018 at 1:05 pm #2898562

rufusB

Hi Itamar, yes, as above, I had to install a backup to regain the original settings as I was unable to edit them. In doing so, I have lost the settings from the Automatic Exchange Rates manual update so until both issues are resolved, none are resolved I'm afraid.

November 13, 2018 at 10:12 pm #2904563

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I've managed to install your site on my local server (it wasn't easy). On my local server, I can update the multi-currency settings. So I still need to investigate this issue. But meanwhile, I've noticed that you are also using the WooCommerce Multi Currency plugin.
Are you sing this other currency plugin?
I suspect that it might cause a collision with the WooCommerce Multilingual multi-currency feature.
Can you please try to deactivate this plugin and see if the issue persists?

Thanks,
Itamar.

November 13, 2018 at 10:47 pm #2904590

rufusB

Hi, I use that plugin on and off as sometimes it seems to make the manual update of the Currency interface editable. Today it didn't. Given that i've tried many permutations with and without it, it's doubtful that it has any bearing on the issue.