Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 24 replies, has 2 voices.

Last updated by rufusB 2 years, 1 month ago.

Assigned support staff: Itamar.

Author Posts
November 14, 2018 at 9:06 am #2905739

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

What exactly are you trying to update manually in the currency section?

Please confirm that it is already agreed between us that the Automatic Exchange Rate is not working because you are using the fixer.io free service with GBP as the default currency.

As I've mentioned the updating of the currency section in WooCommerce -> WooCommerce Multilingual -> Multi-currency is working for me with your site's copy on my local server. Therefore I would like to check if there are any PHP errors while trying to update this section. For this, I've just tried to connect to your site with FTP to enable the debug.log through the wp-config.php file and check if there are any errors. But I could not connect. I've received the following message.

Response:	530 Login authentication failed

Could you please check this and share with me the correct FTP access details?
For this, I'm enabling private message for the next reply.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****

Thanks,
Itamar.

November 15, 2018 at 4:42 pm #2910823

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi and thanks for the access details.

I'm consulting our second tier supporters about this issue.
I'll keep you updated here.

Thank you for your patience.

Itamar.

November 17, 2018 at 9:18 pm #2916434

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

After consulting our second tier supporter, I would like to ask for two things please so we'll be able to continue debugging this issue.

A. Do you have a staging site (or can you create) on the same server where we can debug this issue without breaking your live site?
Our debugging procedure will probably include disabling the theme and all third-party plugins so this why we want to do it on a staging site and not on the live site. If it is not possible for you to create a staging site, then please explicitly allow us to switch the theme on your site and deactivate all the plugins if needed.

B. Can you please get for us the server log?
The server log might contain more information about this problem. Information that we cannot see on the debug.log file in WordPress. Please note that you might need to ask your hosting service where you can get this log. You will need to replicate the problem and recall the exact time of the replication so we will not need to look throughout the entire log for any possible related errors. And this way you can share with us only the part of the log from around the time of the replication of the problem on the site. You can upload the log file to a service like Google Drive or Dropbox and share the link with me. For this and for sharing the access details to a staging site I'm enabling private message for the next reply.

Thanks,
Itamar.

November 18, 2018 at 8:50 pm #2917824

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Thank you for this extra information.

I've shared it with our second tier supporter and we'll keep you updated here.

Thanks,
Itamar.

November 19, 2018 at 12:02 pm #2919310

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

I've escalated this issue to our second tier supporter.
We'll keep you updated here on this issue.

Thank you for your patience.

Itamar.

November 25, 2018 at 5:08 am #2937299

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Our second tier supporter says that he checked this issue and it seems to be working now.
All he did was to purge the Siteground cache. I've just checked it myself, and I can approve that the multi-currency settings are being saved.
Can you please confirm that the issue is resolved now?

Thanks,
Itamar.

November 26, 2018 at 3:53 pm #2941117

rufusB

Hi, yes it did work yesterday, it's not working today. Like I said, the problem is intermittent. so I'm afraid it's still not solved.

Cheers

November 27, 2018 at 9:09 pm #2945948

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

You are correct, and I can see that it is not working now.
I've sent a message to our second tier supporter, and I'll reply here when I have news.

Thank you for your patience.

November 28, 2018 at 9:32 am #2947242

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+02:00)

Hi.

Our second tier checked the issue once again and here is how he manages to make it work.
- Turn off currency for specific language
- Refresh - notice that the currency is still checked
- Use button to purge SG cache on the admin toolbar
- Refresh again - notice that the currency is unchecked
Same applies when checking currency to be enabled for a certain language.

Is it working for you this way?

Regards,
Itamar.

December 7, 2018 at 11:43 am #2977647

rufusB

My issue is resolved now. Thank you!