Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
November 18, 2015 at 10:55 pm #749674

Milos Miladinovic

I am trying to: Edit product in English (original in Serbian)

URL of (my) website where problem appears: kobbler.rs

I expected to see: WPML product editing.

Instead, I got: blank page

November 18, 2015 at 11:27 pm #749680

Bruno

Hi Milos,

Please could you enable debug to see if any error message is displayed? To do it, please check the steps in our documentation: http://wpml.org/documentation/support/debugging-wpml/

Then try again to check the problem. If any error message appears, please paste here in the post for me to see.

Thank you.

November 18, 2015 at 11:29 pm #749681

Milos Miladinovic

Same thing happens when I try to make new product. I make it in Serbian, but when I want to make English translation I either get an blank page or if I manage to make a page with /product/product-name/?lang=en I get 404 when I look for that product in English.

November 18, 2015 at 11:39 pm #749683

Milos Miladinovic

Hi Bruno,

Nothing changed, still get an empty page when I try to make or edit English translation of the product.

I tried to change Product Translation Interface to native WooCommerce product editing screen and got to make it, but when I publish it and wanted to see the product I got 404 error.

Regards,
Milos

November 19, 2015 at 12:15 am #749693

Milos Miladinovic

Same thing happens when I go to WooCommerce Multilingual > Products tab.

November 19, 2015 at 12:18 pm #750108

Bruno

Hi Milos,

You have enabled debug? Any error messages displayed?

Also, I noticed that you are using only 40Mb of memory. Note that to use WPML, you need at least 128Mb: https://wpml.org/home/minimum-requirements/

Please, could you open the wp-config.php file in the root of your site installation and add the following lines right after the php tag?

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

E.g.:

<?php

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Please could you check if the problem still persists after you follow this step?

Thank you.

November 19, 2015 at 12:40 pm #750143

Milos Miladinovic

I've added to wp-config.php :

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true);
define( 'WP_DEBUG_DISPLAY', true);

And no error appeared, only white screen.

I've also added:

define( 'WP_MEMORY_LIMIT', '256M' );
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

to wp-config.php and still get white screen.

November 19, 2015 at 10:08 pm #750729

Bruno

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

*** Please let me know exactly what steps should I follow to see the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

November 20, 2015 at 1:48 pm #751261

Bruno

Hi Milos,

Please could you check if your site is working properly?

I just updated the WooCommerce Multilingual and the problem seems to have been resolved.

Thank you.

November 20, 2015 at 2:01 pm #751276

Milos Miladinovic

You are my hero!

Thanks!