This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by jamiL 2 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
July 29, 2019 at 6:41 pm

jamiL

Hello,

I have a working site using WPML, located at hidden link.
I migrated the site to a new environment, located here: hidden link.

At first, I had the "The site is experiencing technical difficulties." error so I switched to the default theme and disabled all plugins. I enabled them one by one to see which one was generating the error, and after enabling wpml the error came back.

July 29, 2019 at 6:47 pm #4303127

jamiL

The error I get when I activate the plugin is:

Plugin could not be activated because it triggered a fatal error.

Fatal error: Class 'WPML_Action_Filter_Loader' not found in /home/capeprod/capeprod.com/site/wp-content/plugins/sitepress-multilingual-cms/sitepress.php on line 175

July 29, 2019 at 8:25 pm #4303395

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. It seems that not all files were migrated during migration. I just removed the WPML files and then installed it again using the file in the client area: https://wpml.org/account/downloads/. Then I activated WPML and it worked correctly.

Please, let me know if I can help with any other questions you may have about it. I'll be happy to help.

Thank you.

July 29, 2019 at 8:50 pm #4303513

jamiL

Thanks, I have no idea why some files were missing but you fixed the issue!