This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:
I created a "Cancel Confirmation" page that contains the Bookly slug [bookly-cancellation-confirmation]. I have translated this page into Japanese, however, when people click on the link to the "Cancel Confirmation" page it directs them to the English version. I can't get it to link to the Japanese version.
Solution:
Adding this XML to WPML → WPML → Settings → Custom XML Configuration field:

<wpml-config>
    <admin-texts>
        <key name="bookly_url_approve_page_url"/>
        <key name="bookly_url_approve_denied_page_url"/>
        <key name="bookly_url_cancel_page_url"/>
        <key name="bookly_url_cancel_denied_page_url"/>
        <key name="bookly_url_reject_page_url"/>
        <key name="bookly_url_reject_denied_page_url"/>
    </admin-texts>
</wpml-config>

will make the URLs appear in String Translation and make them available for translation.

This topic contains 12 replies, has 3 voices.

Last updated by nathanH-7 3 months, 2 weeks ago.

Assigned support staff: Radu.

Author Posts
June 29, 2019 at 4:54 am #4111077

nathanH-7

Tell us what you are trying to do? I created a "Cancel Confirmation" page that contains the Bookly slug [bookly-cancellation-confirmation]. I have translated this page into Japanese, however, when people click on the link to the "Cancel Confirmation" page it directs them to the English version. I can't get it to link to the Japanese version. Thank you

Is there any documentation that you are following? no

Is there a similar example that we can see? no

What is the link to your site? hidden link

June 30, 2019 at 5:19 pm #4114697

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Can you please confirm that this is the Bookly plugin that you using?
hidden link

This plugin is not in our list of compatible plugins here.
https://wpml.org/documentation/plugins-compatibility/
Not being on this list does not mean that it is not compatible it just means we do not know yet if it is.

Nevertheless, I've found in our forum a similar issue with the Bookly plugin. You can see it here. https://wpml.org/forums/topic/bookly-reservation-plugin-sends-confirmation-messages-in-wrong-languages/#post-1476539
Can you please check if the solution in this link helps to solve the issue that you have?

Otherwise please explain to me how I can see the issue on your site.

Thanks,
Itamar.

July 1, 2019 at 7:46 am #4116173

nathanH-7

That is exactly my problem. However, the directory path "appointment-booking/lib/NotificationSender.php file" no long er exists. So I'm asking them now where the new directory is located.

July 1, 2019 at 9:20 am #4116891

nathanH-7

Hi,

I got the following reply from Bookly:

"I'm afraid it is not the issue on Bookly side. Could you please contact WPML support and ask where the new location of the string is? "

Do you know where it is? Thank you!

July 1, 2019 at 1:23 pm #4119371

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nathan,

My colleague Itamar is not available for the moment so I'll take care of this ticket.
As my colleague said, Bookly was never tested for fully compatibility with WPML. I made a little research and I could see that you're not the first user to have issues using this plugin with multiple languages: hidden link.
Is there any chance that you could give me access to the dashboard area so I can have a closer look at the settings of this plugin and see if there's anything I can do to make the link show in the right language, please? The next reply is private so you can safely send me the credentials.

Thanks,
Radu

July 1, 2019 at 1:41 pm #4119457

nathanH-7

Is this next reply really private? I don't get the usual privacy notification...

July 3, 2019 at 5:06 am #4131797

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nathan,

I set the reply to be private once again. Can you tell me if it's working well this time, please?

Thanks,
Radu

July 4, 2019 at 7:23 am #4140683

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nathan,

Can you send me a link to the /wp-admin/ page too, please? When I'm trying to access this I get redirected to a /login/ link that displays a message that I was successfully logged out. I just need the link to the page where I can use the credentials so I can check the Bookly page.

Thanks,
Radu

July 4, 2019 at 7:54 am #4140901

nathanH-7

Please log in through here: hidden link

July 4, 2019 at 10:59 am #4142537

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nathan,

I added the cancellation link to String translation (hidden link) and the Japanese translation. Can you check try again to click on this button and see if you're taken to the right link, please?

Thanks,
Radu

July 4, 2019 at 12:13 pm #4143063

nathanH-7

Thank you very much. That part works correctly now. However, now that it works, when someone click "cancel" on the Japanese version, it directs them to the English version of this page: hidden link

Could this also be made so that it redirects to the Japanese version? Thank you so much!

July 5, 2019 at 10:05 am #4150101

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hey Nathan,

I made the change to have this new link available in WPML → String translation too. Also, I added a few more other links too, in case you'll need to translate them. Please have a look 🙂

Thanks,
Radu

July 5, 2019 at 12:06 pm #4151179

nathanH-7

My issue is resolved now. Thank you!