This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The header slider button text of the Sydney Theme does not offer an option for translation on the WPML Translation Editor.

Solution: The issue appears as solved after applying a small change to the custom XML configuration inside of the WPML settings.

Relevant Documentation: https://wpml.org/documentation/support/language-configuration-files/

This topic contains 10 replies, has 2 voices.

Last updated by danaR-2 5 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
May 3, 2019 at 10:29 pm #3738249

danaR-2

Tell us what you are trying to do?
I am trying to translate a field in WP customizer called "Text for your call to action button" which is located under "Customizing > Header area > Header Slider".

Is there any documentation that you are following?
I am following these instructions https://wpml.org/documentation/getting-started-guide/translating-theme-options/

I was able to find some of the customizer fields under "theme_mods_sydney" after hitting the "Translate texts in admin screens" link, but the "Text for your call to action button" is not in any of the menus.

May 3, 2019 at 10:50 pm #3738265

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

In cases where strings are not able to be located the issue is most likely on the theme's side, as each string needs to be proper coded inside the theme template files in order to be translatable.

https://wpml.org/faq/language-setup/

I would like to offer you to investigate myself about the string but in case we will not be able to locate it it will be necessary to reach out to the theme author's in order to solve the issue.

Your next reply is set to private by default in order to provide the login credentials.

Kind regards
Andreas

May 6, 2019 at 8:14 pm #3752529

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

In fact, I was able to locate the string on String Translation under the domain "sydney" but the translation does sadlz not show up on front end. Could you please test if translations are working for other strings, otherwise, if we are talking about a general issue, you might consider to change the max_input_vars value of you php.ini to at least 5000.

Would you consider to install our Translation Management Plugin? This way I would be able to apply a custom XML config which hoefully would elad to the fact that he string will get translated.

If you add the plugin you might try it yourself by adding the following markup to WPML -> Settings -> Custom XML Config.

<wpml-config>
<admin-texts>
 <key name="slider_button_text">
   </key>
</admin-texts>
</wpml-config>

If all this will not solve the issue, please install a copy of the Sydney Theme on the following test site in order for me to test it on a new installation. If I can recreate the issue I will escalate it to our compatibility team, who will work together with the theme author´s on a solution.

One Click Login: hidden link

Please leave me short noftification once the theme is installed.

Kind regards
Andreas

May 7, 2019 at 1:53 pm #3758893

danaR-2

I tried all the suggestions on the live site and still could not figure out how to translate the "Click to begin" button so I set up the test site...

On the test site, I copied the Sydney theme over and configured it similarly to the main site. I was able to edit a few of the customizer options here (slider_title_1, slider_subtitle_1, slider_title_2, slider_subtitle_2)...
hidden link

You can see the "Click to begin" button on the translated home page...
hidden link

You can also see the field in the customizer here...
hidden link (under Header area > Header Slider)

May 7, 2019 at 3:31 pm #3759763

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

In der Tat lässt sich der CTA Button Text des Sydney Header Slider Elementes auch auf der Test-Site nicht übersetzen.

Ich habe das Problem an unser Kompatibilitätsteam weitergeleitet, welches sich in Zusammenarbeit mit den Theme Authoren um eine Lösung kümmern wird.

Sobald ich eine Rückmeldung erhalten habe, werde ich mich mit Ihnen umgehend in Verbindung setzen.

Mit freundlichen Grüßen
Andreas

May 9, 2019 at 2:44 pm #3777317

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hallo,

Wir haben weiterhin getestet und leider hatte ich den String für den Button Text nicht direkt finden können. Auf der Test-Site lies sich der String nun erfolgreich übersetzen.

Auf Ihrer Live-Site hingegen lässt sich der String nicht zur String-Übersetzung hinzufügen.

Bitte gehen Sie auf String Translation -> Translate texts in admin screens und suchen Sie nach theme_mods_sydney und klicken Sie auf die domain. Dann suchen Sie nach slider_button_text. Ich kann diesen String markieren, wenn ich allerdings die Eingabe bestätige wird der String nicht unter der domain hinzugefügt.

Bitte deaktivieren Sie alle Plugins, die nicht zu WPML gehören und probieren Sie erneut den String hinzuzufügen. Sollte dies nicht gelingen machen Sie bitte eine kleine Änderung in der php.ini Datei auf Ihrem Server.
Sie verwenden den Wert von maxINputVars = 4000. Bitte ändern Sie den Wert auf mindestens 5000.
Sollten Sie bei den Anpassungen Probleme haben konsultieren Sie bitte Ihren Host-Anbieter.

Ich hoffe wir könne auf diese Weise eine Lösung finden. Lassen Sie mich wissen, ob es funktioniert hat.

Mit freundlichen Grüßen
Andreas

May 9, 2019 at 2:47 pm #3777373

danaR-2

Can you please reply in my native language (English). Thanks,

May 9, 2019 at 5:52 pm #3778581

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am really sorry about this incovenience. Here the same message in English.

I continued to test and the string for the button test was translated correctly on our test site.

On your live site, on the other hand, the string is availabel but can not be added to the string translation.

Please go to String Translation -> Translate texts in admin screens, search for "theme_mods_sydney" and click on the domain. Then search for "slider_button_text". Mark this string, but if you confirm the selection on the bottom of the page the string will not be added to String Translation.

this can have various reasons which for I would kindly like to ask you to proceed as followed.

Please disable all plugins that do not belong to WPML and try adding the string again.

If this does not work, please make a small change in the php.ini file on your server.
You use the value of maxINputVars = 4000. Please change the value to at least 5000.
If you have any problems with the customization, please consult your host provider.

I hope this solved the issue. Let me know if it worked.

Kind regards
Andreas

May 11, 2019 at 5:48 pm #3791129

danaR-2

Our hosting provider updated maxINputVars to 5000. I do see the "slider_button_text" checkbox under String Translation -> Translate texts in admin screens -> "theme_mods_sydney". I check the box and click the Apply button but it still does not get added to the domain "admin_texts_theme_mods_sydney" on the String translation screen. I tried this with the extra plugins disabled. Any other ideas?

May 13, 2019 at 5:59 pm #3801089

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your patience.

The issue appears as solved after applying a small change to the custom XML configuration inside of the WPML settings.

<wpml-config>
    <admin-texts>
        <key name="theme_mods_sydney">
            <key name="slider_button_text"/></key>
    </admin-texts>
</wpml-config>

Thank you very much for your patience.

Kind regards
Andreas

May 14, 2019 at 2:58 pm #3808385

danaR-2

My issue is resolved now. Thank you!