This thread is resolved. Here is a description of the problem and solution.

L'utilisateur cherche à traduire quelques chaînes du thème Genesis Pro
Les chaînes sont stockées comme des options de thème, on a pu configurer leurs traduction avec une configuration XML personnalisée.

<key name="genesis_club_options">
            <key name="display">
                <key name="read_more_text"/></key>
            <key name="menu">
                <key name="search_text"/></key>

Relevant Documentation:

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 3 voices.

Last updated by vibekeF 8 months ago.

Assigned support staff: Jamal.

Author Posts
September 30, 2019 at 3:42 pm


I am trying to find theses words in the string translation section of WPML: "Search" and "Read More" which I have set in the Genesis Club Pro plugin (the plugin allows easy placement of search field in the menu + custom read more text for posts both with and without custom excepts. Here a quick video where I've set these words in the Genesis Pro Plugin: hidden link).

Link to a page where the issue can be seen: hidden link
(search bar in menu + read more text after blog excerts)

I expected to see: German langauge when switching to German version of the website)

I tried to set langauge to English for the Genesis Club Pro domain (link "Languages of domains "above string search results), hoping the strings would appear so that I could translate them, but it didn't work, so not sure how to make WPML find these two sets of words.

Thanks for any guidance.


September 30, 2019 at 3:57 pm #4666195

Diego Pereira

Languages: English (English ) Spanish (Español ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello @vibekef, welcome to the WPML support Forum!

Please try the steps below:
- Make sure you have the Translation Magagement and String Translator extensions active. If not, you can download here:
- Go to WPML → Theme and Plugin Localization → Strings in the plugins
- Select the plugin (Genesis Club Pro plugin) and click on Scan selected plugin for strings
- Go to WPML → String Translation and search for the Strings
- Translate the string, check the Translation is complete field and click on Save.


If you can not find the strings, check it is possible to find it on the Translate texts in admin screen page, like on this link: - maybe the plugin is storing these new strings as options.

Please let me know if it worked for you.

All the best,

October 7, 2019 at 10:29 am #4706277


Hi Diego,

Thanks for your instructions. I tried the first optin, but these words still don't show up. I need to try the second option too, but have to do this at at time that the website doesn't have much traffic, as I understands it will slow down the site a lot while having this function activated.

I will try to do it late this evening, and come back to this then.


October 7, 2019 at 2:16 pm #4708329


Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)


I am Jamal from the WPML Support team, as told by my colleague Diego, the strings are stored as options, you will need to locate them in the admin strings screen and make them translatable. Both strings are under the genesis options, see the attached images.

Check this article for more information

I tried to configure the strings for you, but it could not be done through the save button. So I added the following XML code to custom XML configuration in WPML->Settings

<key name="genesis_club_options">
            <key name="display">
                <key name="read_more_text"/></key>
            <key name="menu">
                <key name="search_text"/></key>

Both strings are now translatable as you may see in the attached image(strings-translation.png).

Best regards,
WPML Support

October 7, 2019 at 2:47 pm #4708669


Thank you so much Jamal! Very much appreciated. Working perfectly now 🙂