This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I want to use a different logo for English. The default language is Turkish.

Solution: Solution here: https://wpml.org/forums/topic/cant-find-where-to-translate-site-logo/#post-3666075

This topic contains 5 replies, has 2 voices.

Last updated by elif-t.K 5 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
April 23, 2019 at 12:16 pm #3663777

elif-t.K

I want to use a different logo for English. (The default language is Turkish).

I searched for the logo link in String translations but it doesn't show up there.

These are the links to the site
hidden link
hidden link

April 23, 2019 at 12:22 pm #3663799

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support.

To take a closer look on this issue, please provide temporary access (WP-Admin and FTP Login info) to your site (preferably staging site), so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

=== Please backup your database and website ===

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

April 23, 2019 at 4:22 pm #3666075

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for login details. I have logged in to your site and enabled logo field translation by selecting ‘ut_site_logo’ checkbox from WPML >> String Translations >> (at the bottom of page) “Translate texts in admin screens” >> theme_mods_brooklyn and hit apply button.

And added logo translation from WPML >> String translation as you can see in the attached screenshot.

Now it appearing correct logo on both languages as you can see in attached screenshot.

Thank you

May 1, 2019 at 3:14 pm #3718723

elif-t.K

Hello Noman,

Thank you for the changes. I saw what you did in the admin interface. I also see the screenshot you sent. But interestingly I still see the Turkish logo on the English site. I've looked into it for some time but I don't understand what's going on. (I deleted the cache. I tried another browser I didn't use for some time. I tried private browsing but the logo is still in Turkish.)

I guess you can't debug the issue while you see the logo in English. I'll look into it in the coming days and let you know once I understand the problem.

Kind regards,
Elif

May 2, 2019 at 9:08 am #3722983

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

I have tried with different browsers and different computers but I can see the correct logo in each language as you can see in attached screenshot. It seems to be cache issue.

Thank you

May 2, 2019 at 10:03 am #3723581

elif-t.K

Hello Noman,

I tried it on another computer. Now I see one of the four logos in English at least. (There is another logo as you scroll down and another two for lower resolutions.)

There is probably some caching mechanism on the serverside. (I deleted the browser cache manually many times, moreover the links to the images are different).

Thank you,
Elif