If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 30 replies, has 3 voices.

Last updated by marcL-24 1 year, 1 month ago.

Assigned support staff: Laura.

Author Posts
July 19, 2018 at 8:07 pm

marcL-24

After installing the Media File Translation plugin, I have this message on the back-end:

"For Media File Translation to work optimally, you must run this installation. This will only take a few moments, depending on the total number of posts present in your WordPress installation."

I click on the "Finish installation" button, but nothing happens, and the black circle keeps rolling.

I have tried the same action with all my plugins removed on after the other, nothing changes.
All my plugins are up to date.

Thank you.

July 20, 2018 at 3:44 pm #2565051

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

could you try to stop the setup (if you haven't already), then going to WPML -> Media Translation and only then click to complete the setup?

July 20, 2018 at 5:06 pm #2565259

marcL-24

I can't stop since it never starts. It is not working better using WPML -> Media Translation.

July 23, 2018 at 8:00 am #2568907

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

The problem is it doesn't start or it doesn't end?
I logged in and tried to activate Media Translation, it requires to do the setup. Considering you have 28.000 images it can take quite a lot of time.

However, since your site is so heavy, there could be some errors, so please enable the WordPress debug log. This will allow us to see if any PHP errors are being produced. More Info: https://codex.wordpress.org/Debugging_in_WordPress

Edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Then activate Media Translation and try to run the setup for a while.

Locate the debug log in: /wp-content/debug.log

Paste the latest lines here. No need to paste the entire log file, just 50 lines or so will do. Please censor any sensitive information.

July 23, 2018 at 9:25 am #2569102

marcL-24

It does not start: I ran the process for 16 hours, nothing changes. I know WPML is quite slow, but I hope I don't need to wait longer...

Since the process does not start, there is no debug.log in the wp-content file.

July 23, 2018 at 9:58 am #2569190

marcL-24

On the other hand, I used this link https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors to try to locate other errors. Here is the result:

jquery-migrate.js:23 JQMIGRATE: Migrate is installed with logging active, version 1.4.1
blob:hidden link

Failed to load resource: net::ERR_FILE_NOT_FOUND
jquery-migrate.js:45

JQMIGRATE: jQuery.fn.live() is deprecated
migrateWarn @ jquery-migrate.js:45
jquery-migrate.js:47

console.trace
migrateWarn @ jquery-migrate.js:47
4/wp-admin/admin-ajax.php?_fs_blog_admin=true:1

Failed to load resource: the server responded with a status of 400 (Bad Request)
jquery.js:4

POST hidden link 400 (Bad Request)
send @ jquery.js:4
ajax @ jquery.js:4
connect @ heartbeat.js:375
(anonymous) @ heartbeat.js:453

jquery.js:4 POST hidden link 400 (Bad Request)
send @ jquery.js:4
ajax @ jquery.js:4
connect @ heartbeat.js:375
(anonymous) @ heartbeat.js:453
setTimeout (async)
scheduleNextTick @ heartbeat.js:451
focused @ heartbeat.js:488
(anonymous) @ heartbeat.js:185
dispatch @ jquery.js:3
r.handle @ jquery.js:3

July 24, 2018 at 7:24 am #2572358

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

could you try running it after disabling all other plugins and switching to a default theme like TwentySeventeen?

July 24, 2018 at 8:40 am #2572560

marcL-24

I have already done it. Did not help.

July 25, 2018 at 7:43 am #2578418

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I tried to start it my self and it gives errors, probably related to JavaScripts.
I escalated the ticket to the second tier, I'll let you know as soon as possible.

July 26, 2018 at 1:12 pm #2584349

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I would need a copy of your site to further debug. We usually suggest Duplicator plugin to create it.
I'll enable a private reply so you can share the link with me

July 27, 2018 at 11:05 am
July 27, 2018 at 3:24 pm #2588826

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

I downloaded the database with your link and the ofter files I needed via FTP.
I'll do some tests and get back to you as soon as possible.

July 30, 2018 at 8:16 am #2592994

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

on my copy the setup is really slow but it seems to go on.
Did you get this message "In order to get WPML Media Translation fully working, you need to run this set up which takes only a few moments depending on the total number of posts in your WordPress install." or it stops before that?

July 31, 2018 at 5:14 pm #2599362

marcL-24

Yes, I have this message "In order to get WPML Media Translation fully working, you need to run this set up which takes only a few moments depending on the total number of posts in your WordPress install", but it never runs.

Can you please re-read my first message from July 19th? I have been writting it already.

I have opened this issue more than 12 days ago and if I got it right, you still don't understand what I am going through?

Help here. Is there anyone else able to deal with my issue?

August 1, 2018 at 7:16 am #2600771

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I was asking because, on my local server, the process did start after 10 minutes or so.
I escalated the ticket to developers when I have news I'll update the thread.