Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Ricardo Alday 2 years, 2 months ago.

Assigned support staff: Ricardo Alday.

Author Posts
July 11, 2018 at 12:45 am #2484804

setyo-hadiJ

Check my homepage hidden link and my translation page hidden link

I can translate most of text, But I cant found where image translation, which is I should change link goes to when image is click (Images is below slider if you see my images)

PS I use WP bakery builder

Frontpage hidden link

Backend hidden link

July 11, 2018 at 4:59 pm #2487701

Ricardo Alday

Hi,

Thanks for contacting support. I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.

If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Thanks

July 13, 2018 at 9:52 pm #2492827

Ricardo Alday

Hi,

In your WordPress dashboard go to WPML -> Settings -> Custom XML Configuration and paste the following code:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>bsf-info-box</tag>
            <attributes>
                <attribute encoding="vc_link">link</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

and save.

Then edit your homepage in the original language, make any small edit and update, then update the translation. You should now be able to translate the links for images in the Info box elements.

Hope that helps.

July 16, 2018 at 1:58 am #2527354

setyo-hadiJ

Dear Ricardo, thats only fix Info box only?

If I use single images, like this page hidden link

I cant translate link inside also.

July 17, 2018 at 5:54 pm #2530740

Ricardo Alday

Yes, the code only works for info box. To support image links such as on the page that you linked you need this additional code:

<shortcode>
            <tag>vc_single_image</tag>
            <attributes>
                <attribute>title</attribute>
                <attribute>image</attribute>
            </attributes>
        </shortcode>

So the complete custom XML code should look like this:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>bsf-info-box</tag>
            <attributes>
                <attribute encoding="vc_link">link</attribute>
            </attributes>
        </shortcode>
<shortcode>
            <tag>vc_single_image</tag>
            <attributes>
                <attribute>title</attribute>
                <attribute>image</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Note: This way, you would be "translating" the image ID.

Hope that helps.

July 18, 2018 at 12:36 am #2531115

setyo-hadiJ

Dear ricardo, I dont want to translate ID

I want to translate image link.

hidden link

July 18, 2018 at 6:56 pm #2533014

Ricardo Alday

My mistake. This is the complete code you need:

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>bsf-info-box</tag>
            <attributes>
                <attribute encoding="vc_link">link</attribute>
            </attributes>
        </shortcode>
        <shortcode>
            <tag>vc_single_image</tag>
            <attributes>
                <attribute>link</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

You need to edit the Single Image element in the original language, any simple edit will be enough. Update the page and then update the translation.

Hope that helps.

The topic ‘[Closed] Cant found where image translation WPBakery’ is closed to new replies.