This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by usahello 2 months, 3 weeks ago.

Assigned support staff: Lauren.

Author Posts
June 14, 2019 at 5:01 pm #4023115

usahello

If I have a page in my original language and then translate it into a different language everything is fine. Then if I attach a featured image to the original language page hit "update" then click to update the translation I am taken to the translation editor and I see the media for the featured image along with translation fields for the image title and alt text. However, after I translate those two fields and save the translation I don't see the featured image display on the front end for the translated page.

June 17, 2019 at 4:54 pm #4037341

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I was able to edit the media fields in the translation editor after activating String Translation and adding the media title, description, caption, etc at the time of upload.

Please go to Pages and edit the translation for "test test test" and you will see the media fields there.

Please try these same steps on your site with minimal settings and let me know if the issue persists. Thanks!

June 17, 2019 at 5:46 pm #4037607

usahello

I'm still seeing the same issue on your demo site. I create a new page in English without a featured image. I translate the page into Spanish. Then I add a featured image to the English page by uploading a new .jpg and including some text in the alt and title fields. Then I edit the Spanish translation, but don't see the featured image meta fields available for translation. However, the featured image does show up on the front-end for the translated page.

June 17, 2019 at 7:20 pm #4038189

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I edited the page content, and now I can see the media fields in the translation editor. Can you please test and confirm that you get the same results?

June 18, 2019 at 2:02 pm #4044281

usahello

I just tested on the demo site and can confirm that once I edit the page content then the image meta fields show up in the translation editor. I tested the same process out on our staging site as well and saw similar results.

June 19, 2019 at 4:33 pm #4053427

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have escalated this issue to our 2nd tier support team so that they can further troubleshoot. I'll update here as soon as I have more information.

July 10, 2019 at 7:53 pm #4184241

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Here are the steps that our developers suggest in order to add the media to translation, if you prefer not to update the post content.

1. Create a page
2. Translate that page with Classic Translation Editor (CTE)
3. Go back and add a featured image to the original post
4. Check in the CTE if the image appears - it does not
4. Send the translation (and select the media because you have that option) using the Translation Management page in WPML
5. Take the translation job from WPML -> Translations and translate the post. Notice the image appears now.

Please let me know if you need any further assistance and I will be happy to help.

July 26, 2019 at 2:41 pm #4290187

usahello

Thanks Lauren, but this process doesn't fully work. When I follow the steps I do see the featured image alt and title fields appear in CTE for editing, but after saving the translation the image itself does not show up on the front-end.