This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: How to set language switcher in homepage

Solution: Generate menus at Appearance -> Menus and translate them. Enable the menu language switcher which can be activated at WPML -> Languages -> Menu Language Switcher. The language switcher option will only be available, if there is currently a translation for the content available.

Relevant Documentation: More information about this topic you can find here: https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

This topic contains 9 replies, has 2 voices.

Last updated by suayipe-2 4 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
April 11, 2019 at 10:59 am #3586461

suayipe-2

I am trying to: get the language switcher on homepage and link both languages to one page so i can edit it later

Link to a page where the issue can be seen: hidden link

I expected to see: a widget or language switcher

Instead, I got: nothing, no language switcher just a normal page.

April 11, 2019 at 6:42 pm #3592161

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting WPML Support.

In case of your homepage I would advise you to enable the menu language switcher which can be activated at WPML -> Languages -> Menu Language Switcher.

It is necessary to have a proper menu setuo and translation at Appearance -> Menus to place the language switcher in the section.

More detailed information here:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

In case the language switcher will not appear please reach out to me again.

Kind regards
Andreas

April 12, 2019 at 6:55 am #3595323

suayipe-2

It didn't show up, is there a way to give you my wordpress admin and fix that for me?

April 12, 2019 at 1:33 pm #3599485

suayipe-2

Can I get someone to help me fast please

April 12, 2019 at 7:00 pm #3601365

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

My apologies for the delay on my answer.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

April 12, 2019 at 9:47 pm #3602079

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am not sure if I understood your request correctly.

I have enabled the WPML Menu Language Switcher. You can enable different language switcher options on your Dashboard at WPML -> Languages.

More information about this topic you can find here:
https://wpml.org/documentation/getting-started-guide/language-setup/language-switcher-options/

Please take note that the language switcher will only show another language option if the content is already translated into the respective language.

Let me know if you need any further assistance.

Kind regards
Andreas

April 13, 2019 at 5:20 am #3603639

suayipe-2

Please I need you to set the original homepage to all different languages and i'll be able to translate it later, I don't know how to set the main homepage to the other languanges, because it shows 404 this page cannot be found.

April 13, 2019 at 9:57 am #3604175

suayipe-2

My issue is resolved now. Thank you!

April 13, 2019 at 9:58 am #3604179

suayipe-2

I fixed the issue, thanks for the help.

April 13, 2019 at 9:59 am #3604181

suayipe-2

My issue is resolved now. Thank you!