This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: Enabling some WPML options leads to white screen and site stopped working.

Solution: Disabling https://wordpress.org/plugins/insert-post-ads/ solved the issue.

This topic contains 5 replies, has 2 voices.

Last updated by nicolasC-23 1 month ago.

Assigned support staff: Riffaz.

Author Posts
September 15, 2019 at 3:21 pm #4574899

nicolasC-23

I am trying to:
My goal is to remove the active language from the language switcher.
Link to a page where the issue can be seen:
not really much to see on frontend but emadion.it
I expected to see:
An option to do so. This https://wpml.org/forums/topic/hide-active-language-2/

Instead, I got:
I can't find the option. The plugin settings are also messed up.

September 15, 2019 at 3:51 pm #4575005

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

It seems you have some incompatible issue.

1) do you see any error message in your console when you try these options? https://wordpress.org/support/article/using-your-browser-to-diagnose-javascript-errors/#step-3-diagnosis

2) if you disable all the plugins except WPML and check the issue, do you see the same issue?

3) what do you see when you try these options after enabling WP Debug mode? https://wpml.org/documentation/support/debugging-wpml/

Let me know.

Regards,
Riffaz.

September 15, 2019 at 4:57 pm #4575065

nicolasC-23

I found that the error happens when this plugin is enabled: https://wordpress.org/plugins/insert-post-ads/

I see the option now, but It's grayed out and seems to only apply to a switcher attached to the menu?

I'm using

do_action('wpml_add_language_selector');

How can i hide current language on it?

September 16, 2019 at 12:51 pm #4580251

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

I found that the error happens when this plugin is enabled: https://wordpress.org/plugins/insert-post-ads/
- so this plugin does not comply with some standard WordPress coding or procedure or might be some other error with it.
- please contact the plugin support and ask theme regarding this.
- they will be able to find the cause of this.

I see the option now, but It's grayed out and seems to only apply to a switcher attached to the menu?
- no, it should not be.
- see this footer menu and I see the option to hide it: hidden link

https://wpml.org/wp-content/uploads/2019/09/4575065-error_41.png
- none of these errors come from WPML
- but these are javascript errors.
- and the option you are having issue with also requires JavaScript
- so there are higher chances that this could make the issue.
- you can find which plugin causes this by deactivating one by one.
- when you do not see any error there the option should work fine without 'Insert post ads'

Regards,

September 16, 2019 at 3:02 pm #4581775

nicolasC-23

Hi, ok so i disabled that plugin. No errors on console. All options work. But still need help to hide current language.

The option was grayed out cos i had selected "drop-down" menu. And drop-down is not compatible with hiding current language.

But this is irrelevant to me. Since i'm not using a footer switch. I'm using

do_action('wpml_add_language_selector');

and it's not affected by those settings.

This is what i'm looking at (see pic). I see no option to hide current language.

September 16, 2019 at 3:06 pm #4581811

nicolasC-23

My issue is resolved now. Thank you!
The option is down below under "Personalizza i selettori di lingua"
As feedback, i believe the options are a bit all over the place. All related options should be on same screen, close to each other.
Also maybe there's a way around it but i'd prefer the settings be in English instead of Italian (the site language). Italian is confusing for technical mumbo-jumbo.