We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 15 replies, has 2 voices.

Last updated by nathanH-7 3 months, 4 weeks ago.

Assigned support staff: Bigul.

Author Posts
June 29, 2019 at 5:05 am #4111105

nathanH-7

Tell us what you are trying to do? I'll try to explain this as best I can because I can't get the "Upload an image" button to work on this forum. After someone makes a booking on my site and goes to the Customer Cabinet (which I have linked on a page called "My Bookings") to view their booking, the English version shows up under the "Service" tab. I can't find where the translation string is for this. Thank you!

Is there any documentation that you are following? no

Is there a similar example that we can see? no

What is the link to your site? hidden link

June 30, 2019 at 6:10 pm #4114735

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I would like to access the admin area of your site for further checking. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

July 1, 2019 at 6:58 pm #4121889

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the login information. Now the *My Booking* page is showing *You don't have permissions to view this content.* message for me. It is only visible for the customer users? If so, please share me a customer user details.

Please check the attached image and let me know your feedback.

--
Thanks!

Bigul

July 1, 2019 at 11:38 pm #4122499

nathanH-7

Apologies for that. If you make a booking, it will appear. I will make one now so you can see it.

July 2, 2019 at 7:30 am #4124695

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following steps and check you are getting the expected result.

1) Visit WPML>>Languages>>Language URL format
2) Choose *Different languages in directories* option
3) Save the changes
4) Visit Settings>>Permalinks
5) Resave the settings

--
Thanks!

Bigul

July 2, 2019 at 10:36 am #4125801

nathanH-7

Just to be clear, I currently have the setting on "Language name added as a parameter". Does this not work? That is, should I change the setting to "Different languages in directories "in contrast to what I have now? All of my other pages work with no problem.

July 2, 2019 at 1:28 pm #4127365

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have requested to change the URL format as a part of debugging. Because maybe the Language parameter will be missing after the reservation in Japanese. Please check it and let me know your feedback.

--
Thanks!

Bigul

July 2, 2019 at 2:12 pm #4127753

nathanH-7

Hi,

After following those steps, it is still showing up in English. I've attached a picture for you to see.

July 3, 2019 at 6:15 am #4132113

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback. I have a request. Please allow me to make a duplicator copy of your site using the Duplicator plugin(https://wordpress.org/plugins/duplicator/) for debugging the issue on my local server.

--
Thanks!

Bigul

July 3, 2019 at 7:49 am #4132741

nathanH-7

Okay, yes, please do.

July 3, 2019 at 5:46 pm #4138433

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I made a Duplicator copy of your site and debugging the issue now. Will get back to you as soon as possible. Please wait.

--
Thanks!

Bigul

July 4, 2019 at 12:27 pm #4143205

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, the issue is existing after my initial debugging steps and can reproduce the issue in a fresh installation. Bookly Service and Category strings are not showing the translation. It looks like *bookly-customer-cabinet* shortcode is not compatible with WPML and *bookly-appointments-list* shortcode is working fine for me. Please check the attached images for more details.

Therefore I have escalated the ticket to our compatibility team for further debugging. We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

July 12, 2019 at 12:42 pm #4198883

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

The issue is happening because the code to list the Service and Category terms are not compatible with WPML. It works in our local copy after the following steps. Please try it after a site backup and let me know your feedback.

1) Go to *wp-content/plugins/bookly-addon-customer-cabinet/frontend/modules/customer_cabinet* folder
2) Open *Ajax.php* file for edit
3) Scroll to line 155
4) Change the code with the following one

'service_title'    => apply_filters( 'wpml_translate_single_string', $row['service_title'], 'bookly', 'service_' . $row['ca_id']) . '<br/>' . implode( '<br/>', array_map( function ( $extras ) { return $extras['title']; }, (array) BooklyLib\Proxy\ServiceExtras::getCAInfo( $row['ca_id'], false ) ) ),

5) Scroll to line 156
6) Change the code with the following one

'category'         => apply_filters( 'wpml_translate_single_string', $row['category'], 'bookly', 'category_' . $row['ca_id']),

Please check the attached images for more details.

--
Thanks!

Bigul

July 17, 2019 at 9:44 am #4228333

nathanH-7

Great! That worked perfectly. Now, will this change be reverted back if Bookly issues an update for this plugin?

July 17, 2019 at 3:16 pm #4231605

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. This changed will be reverted back if we upgrade Bookly plugin.

Bookly plugin is not listed in our compatibility list for the plugins. Can you please request Bookly team to apply for the Compatibility program. So we can include this fix officially.

https://wpml.org/documentation/theme-compatibility/go-global-program/

--
Thanks!

Bigul