This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 14 replies, has 2 voices.

Last updated by Luca 1 year ago.

Assigned support staff: Vuk.

Author Posts
October 7, 2018 at 8:19 pm

Luca

I am trying to:
Localize Divi email-optin module
Link to a page where the issue can be seen:
hidden link
I expected to see:
I expect to see the email optin module fields in the Page translation, in particular the "Description", "Footer" and Success Action "Message"
Instead, I got:
Only the "Title" field shows up. The button text is translated automatically (mo file ?), the rest doesn't translate automatically and is not available for translation

October 8, 2018 at 7:43 am #2794952

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

Hi,

Can you please share your site credentials in the boxes provided, so we can assist you.
NOTE: Make sure you do complete site backup before sharing.

Warm regards

October 8, 2018 at 8:03 pm
October 9, 2018 at 11:04 am #2799628

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

It looks like it is a bug, I see that Divi config file is not loaded properly form our CDN.

I've forwarded issue to our dev team and they are working on it as we speak.

Please be patient, I'll update you asap.

Have a great day!

October 10, 2018 at 2:05 pm #2804661

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

Hi,

We've tested issue and realized that we had bug in our testing tool.
Divi configuration file was loading properly.

So I've tested it again and created new page (you will see it in your dashboard).
I've added button and email optin modules and translation parsing is working.

I suggest deleting your old page and recreate new one.

Best regards

October 10, 2018 at 7:59 pm #2805690

Luca

Hi Vuk,

In your page, the specific fields description and footer are not there. You entered 21, 22, 23, 24, 25 in the Divi module, but only 21, 22 and 25 were available in the translation strings. Take a look again, 23 and 24 (description and footer) are not there. So there is an issue with those two fields.

Best

Luca

October 11, 2018 at 12:14 pm #2808069

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

Hi Luca,

Those two fields were missing from the config file used between Divi and WPML.

We've updated config files in our repo and I've checked your site is properly loading it.
However, I still can't get it to work with Translation Editor.

I've checked locally and it is working fine for me.
Can you please check if there is some kind of caching related to your hosting?

Warm regards

October 11, 2018 at 2:08 pm #2808555

Luca

Hi Vuk, not that I know of. It is a vanilla Ubuntu + Apache setup that I manage directly. I restarted Apache, then I rebooted the server, fields are not showing up. As you saw there are almost no plugins, and I disabled Jetpack CDN just in case although that's only for media files, normally. Doesn't this config file require a new plugin version ?

October 11, 2018 at 5:06 pm #2809248

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

Hi,

It was related to our CDN, we forced update and now it is ok.
Please take a look at "wpml 2" test.

Also, we are not sure why it happened with first post.
It happened to us once when we debugged locally and now we can't replicate it.
If you stumble upon again please report it, so we can deal with that too.

Have a great day!

October 11, 2018 at 5:33 pm #2809313

Luca

Hi Yuk, it is there now. But the field is displayed as a simple string, not as a full text field. See attachment (last one in the screenshot)

October 12, 2018 at 11:54 am #2811816

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

Hi,

Yes you are right, but at the moment WPML supports "text field" types of fields only for custom fields.

Warm regards

October 12, 2018 at 12:00 pm #2811844

Luca

Ok, but this is how it localises then, see image, which makes the localization useless. Any workaround ?

October 12, 2018 at 2:46 pm #2812354

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

That we can solve. It is caused because html tags by default are not allowed. Please take a look at it now.

I've specifically allowed html tags for that shortcode in config file setting in WPML > Settings > Custom XML configuration.

More about it you can read here: https://wpml.org/documentation/support/language-configuration-files/#page-builder-content

Have a great day!

October 12, 2018 at 5:08 pm #2812742

Luca

Thanks ! Works fine. A bit "harder" to edit, but it works perfectly fine, and it is not like these change every day 😉

October 15, 2018 at 6:57 am #2816366

Vuk
Supporter

Languages: English (English )

Timezone: Europe/Belgrade (GMT+02:00)

Great, happy to help you out. Please mark thread as resolved, and contact our support if you ever encounter any other issue,

Cheers!