This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 17 replies, has 2 voices.

Last updated by Lauren 1 month, 2 weeks ago.

Assigned support staff: Lauren.

Author Posts
August 16, 2019 at 6:01 pm

johnM-63

I am trying to: login using the link that says click here to login as returning customer on the checkout page

Link to a page where the issue can be seen: add a product to cart then go here hidden link
now click the link to login as existing customer (or Cliquez ici pour vous connecter)

I expected to see: if you enter correct details, it should login you in, if you enter incorrect details you should get a login error. neither of these happen

Instead, I got: page just refreshes.

if i DISABLE wpml, the login works fine as expected.

August 16, 2019 at 6:14 pm
August 16, 2019 at 6:17 pm #4407845

johnM-63

it works fine if wpml is deactivated, and with all the plugins we have, its not possible to deactivate them all to test that.

August 16, 2019 at 6:33 pm #4407859

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Are all of the WooCommerce pages translated?

I will need to test with all other plugins deactivated in order to rule out a conflict as a cause of the issue. I will be happy to set up a copy of your site so that I can test that for you without affecting your live site.

To best troubleshoot the issue, please make a snapshot of your site using the Duplicator plugin: https://wordpress.org/plugins/duplicator/. This will allow me to try and duplicate the error so that I can run further tests without interrupting your live site.

Once the snapshot is complete, either upload the snapshot ZIP file and the installer.php file to a file sharing service such as Dropbox (and share the link in your reply) or right click the Duplicator links in your wp-admin and paste in your reply.

Please note: It is important to reduce the size of the package so please exclude some paths like /cache or /uploads and also exclude archives and media files.

I will also need the username and password of an account that was created BEFORE creating the duplicator package.

I will enable the next reply to be private so only you and I have access to it!

August 16, 2019 at 7:09 pm
August 16, 2019 at 9:18 pm #4408213

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I can confirm that with only WooCommerce and WPML plugins, you are able to login without any problem from the checkout page.

I will continue testing but it will take some time to try and isolate which plugin is causing a conflict. I will update here when I have more information.

August 16, 2019 at 10:01 pm #4408265

johnM-63

its the WooCommerce Multilingual that i deactivated to make it work on my end. ok since your email i checked ones that i thought might be the ones, and found that it is ithemes security enabled along with wordpress ML causes the issue. how can we solve this?

thanks

August 16, 2019 at 10:02 pm #4408267

johnM-63

sorry wordpress ML should have said woocommerce ML

J

August 16, 2019 at 10:12 pm #4408315

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I have found that when I activate the GP Premium plugin, then I cannot open the login link. It opens for a moment and then I cannot access it.

Please try deactivating the GP Premium plugin, and let me know if the issue persists on your live site. Thanks!

August 16, 2019 at 10:19 pm #4408329

johnM-63

no its not gp premium just tested that and it makes no difference on the issue
its something between woocommerce ML and ithemes security.

August 19, 2019 at 1:31 pm #4416481

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

If you disable the iThemes Security plugin, are you able to login successfully? I also see that there is an update available for the iThemes Security plugin. Please try updating and see if anything changes.

Lastly, are there any caching options on the iThemes Security plugin, or ajax settings? It may be that some settings need to be changed to allow it to work correctly. In my test site, I am able to login with the iThemes Security plugin still active, which makes me thing perhaps it is a setting that is preventing it from working on your site.

August 22, 2019 at 3:50 am #4436195

johnM-63

yes that does work, ok , but it also works if i disable Woocommerce ML plugin (ithemes still active) so its a conflict between your plugin and ithemes security.

August 22, 2019 at 2:29 pm #4440361

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for confirming the settings on your site. To make sure that the conflict is happening with just WooCommerce Multilingual and iThemes Security, I have set up a fresh install. Please install the iThemes security plugin there and make sure all settings match your live site so that we can try to reproduce the problem. Thanks for your assistance.

One Click Login:hidden link
Username:demo
Password:20reH94FvExY

August 22, 2019 at 4:09 pm #4441473

johnM-63

Hi Lauren,

ok sure but dont you already have a full replica of my site to check? ill look at this shortly.

John

August 22, 2019 at 5:07 pm #4441789

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

I do have a copy of your site. However, with only these plugins active I am able to login without any issue:
WPML core
String Translation
Translation Management
WooCommerce Multilingual
WooCommerce
iThemes Security

Which is why I would like to test on a fresh install so that you can check the settings and try to reproduce the error.

The topic ‘[Closed] cant login as a returning customer on checkout page when wpml is active’ is closed to new replies.