Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 9 replies, has 2 voices.

Last updated by Radu 8 months, 3 weeks ago.

Assigned support staff: Radu.

Author Posts
March 4, 2019 at 8:56 pm #3270634

matthewA-7

We are using multiple domains, one for each language. We can preview changes on the primary domain, but we get an error saying "Sorry, you are not allowed to preview drafts" on the second domain. Some notes:

- We are using the "Auto sign-in and sign-out users from all domains" setting. If we disable that, and log into each domain separately, it seems to work (as long as we click "preview changes" from the domain of the language we want to preview).
- We are hosting on WPEngine and have contacted their support already. They told us everything looks good on their end (.htaccess file etc.)
- We have tried disabling all plugins (except WPML) and reverting to the default theme. This does not resolve the issue.
- We are using version 4.2.4.1 of the plugin.

March 6, 2019 at 9:08 am #3277689

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Matthew,

Thank you for reaching out the WPML support!

Is there any chance that you could give me access to the dashboard area so I can check this out a bit closer? I would've asked to deactivate the plugins and try another theme but I can see that you already did this (which is great, well done). In this case, I need to have a look at the setting by myself and see what's going on.

Thanks,
Radu

March 7, 2019 at 2:34 pm #3284935

matthewA-7

I can. How do I share the credentials securely?

March 7, 2019 at 2:50 pm #3285002

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Matthew,

You can add the credentials here. Your next message will be private so just you and I will see the login data.

Regards,
Radu

March 8, 2019 at 12:19 pm #3292056

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Matthew,

I checked the Dashboard → WPML → Languages → Language URL format and I could see that there's a message saying that languages per directories will not function. Can you check once again that you made all the changes presented in this article https://wpml.org/2016/04/use-wpml-different-domains-per-language/ for setting up the different domain option, please? If you have troubles setting up the server options, you can reach out to the hosting provider and I'm sure that he'll be able to handle all the changes for you in no time.

Also, here's a very helpful article with some tips about some key options required by this different domains option (like PHP modules, for example) https://wpml.org/documentation/getting-started-guide/language-setup/cannot-activate-language-directories/. Please check this out too and make sure that everything is configured as explained. This is an area where you can ask for some help from the hosting too.

Thanks,
Radu

March 8, 2019 at 2:53 pm #3293328

matthewA-7

We don't want to use the "Different languages in directories" setting. We have "A different domain per language" setting selected.

The domains are working as expected to view the site. I can go to the english domain and view the english site, and I can go to the french domain to view the french site. It's only the preview that isn't working. E.g. I go into a post, make a change and click "Preview Changes". That is when we get the error: "Sorry, you are not allowed to preview drafts".

We followed those steps outlined in the guide when we set everything up.

March 11, 2019 at 9:02 am #3308859

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Matthew,

I edited this post: hidden link, made it Draft, and tried to preview it. Everything worked well. Is there any other way I can check try this out to see the problem?

Thanks,
Radu

March 11, 2019 at 1:10 pm #3312589

matthewA-7

It works now because we disabled the "Auto sign-in and sign-out users from all domains" setting as a temporary override so we can get it working for our client. The problem is, now they have to log into each site individually in order to preview.

March 14, 2019 at 1:39 pm #3345081

matthewA-7

Any update on this issue?

March 14, 2019 at 3:14 pm #3346141

Radu
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+02:00)

Hey Matthew,

Sorry that I didn't give you an update about this. I tried a couple times to replicate this issue on my side but I had no luck with that. I still think that we need to take care of the notice from Dashboard → WPML → Languages → Language URL format. Everything else might be working fine but having that message might be causing the error with the preview. So first, please contact your hosting and make sure that the server can write the .htaccess file and that URL rewriting is enabled.

Basically, when using the preview option, WPML will automatically go to the second domain and preview the post. However, if these two conditions are not met (along with other ones), the will try to preview the content from the main domain which is not possible.

Thanks,
Radu

The topic ‘[Closed] Can't preview changes on second domain’ is closed to new replies.