This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I can't seem to add the site key. We had to restore this site from a backup recently, and what we found is that WPML site key doesn't work.

Solution: Solution here: https://wpml.org/forums/topic/cant-save-the-site-key/#post-4102079

0% of people find this useful.

This topic contains 2 replies, has 2 voices.

Last updated by Kim 3 months, 3 weeks ago.

Assigned support staff: Noman.

Author Posts
June 27, 2019 at 5:07 pm #4101779

Kim

I can't seem to add the site key. WE had to restore this site from a backup recently, and what we found is the wpml site key doesn't work. so i've deleted the original one, and created a new one. But when i try to add it to the site, it just spins and spins, and never saves it

June 27, 2019 at 6:24 pm #4102079

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Could you please follow below steps and let me know how it goes?

- I have noticed that your website’s WP Memory Limit is 40MB. The WP memory limit needs to be increased, it's different than php memory. PHP memory is fine but WordPress uses 40Mb as default in your site. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Please add this to the top of wp-config.php to increase WP memory:

/* WP Memory Limit */
define('WP_MEMORY_LIMIT', '512M');
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

=== Please backup your database and website ===

- You are using an older version of WPML plugins. Please backup your site and update ALL WPML plugins to it's latest versions. You can download it from your account: https://wpml.org/account/downloads/

- This problem might be related to a Javascript conflict. Could you please open a Javascript console in the browser (usually F12 key) before pressing ‘Ok’ button? And let me know if you find any warnings/errors in console after pressing that button.

- Please delete all sort of caches on your site / server cache (Litespeed) / plugin cache / CDN cache (if any), clear browser cache and then check the page.

- Please check for a possible theme and plugin conflict. To do that you can switch back to any default theme (e.g. Twenty Seventeen theme), Disable all plugins except WPML and see if this issue goes away with default theme and only WPML activated?

Thank you

June 28, 2019 at 10:36 pm #4110267

Kim

My issue is resolved now. Thank you!