This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Yvette 1 year ago.

Assigned support staff: Yvette.

Author Posts
October 10, 2018 at 2:11 pm

henrikO-5

Hi,

I have installed WPML and also have WP Bakery installed. I want to translate the pages on my website. But when I click on "translate" on each page - not all fields is translatable.
I just can see the HTML-code to the left but not the text.

The widget (Change between langugaes) doesnt work either. Only one language is visible.

Can you please help me 🙂

All the best,
Henrik

October 11, 2018 at 2:42 pm #2808705

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

For some reason, your system is not downloading the remote wpml-config.xml for visual composer which is found here:
hidden link

I cut&paste the relevant content of this file into you WPML -> Settgins -> Custom XML Configuration

Now the posts are parsing.

Can you please check that the other pages are parsing ok?

October 12, 2018 at 9:51 am #2811493

henrikO-5

Hello Yvette,

thank you! Now most of the posts and text is visible 🙂
But.. for some reason the "ICON BOX with text" isnt visible?
Se attached image.

Also.. the widget for language switch doesnt work in the footer.
See attached image. Only swedish is visible.. not english..

All the best,
Henrik

October 12, 2018 at 1:49 pm #2812224

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

1. Icon box
I´ve added the shortcode to the XML custom configuration tab.
You can see that it is visible in the translation editor with this page:
hidden link

2. Footer language switcher
The WPML language switcher will only show a language as selectable if a translation exists. Once I translated the Front page, the switcher now shows the English option to select.

I hope this now resolves your issues.

October 12, 2018 at 8:12 pm #2813038
henrikO-5

Yvette,

thank you so much 🙂

The only thing now I have a problem with is: placing the "currency switcher" in the menu bar?
I can place the language switcher there but NOT the currency switcher.

I have tried plugins for shortcodes - but they doesnt work.
Is the only way to do custom coding for this?

Henrik

New threads created by Yvette and linked to this one are listed below:

https://wpml.org/forums/topic/split-cant-place-currency-switcher-in-the-menu/

October 14, 2018 at 4:19 pm #2815613

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

I¨ve split this new topic onto a new ticket as it is not related to the original issue.

If the original issue is resolved - we can close this ticket.