This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 2 voices.

Last updated by nikiN 1 year ago.

Assigned support staff: Ricardo Alday.

Author Posts
September 24, 2018 at 4:08 pm

nikiN

I am trying to: Translate a custom post

Link to a page where the issue can be seen: any Escort type post

I expected to see: Translation manager for the fields

Instead, I got: nothing

September 26, 2018 at 12:46 am #2765406

Ricardo Alday

Hi,

Thank you for contacting WPML support.
I checked the open a translation of one of your Escort post types and the ATE interface shows the values for all the fields from the "Details" ACF field group. Were you able to fix the issue or are there any particular fields still missing from the ATE interface?

September 26, 2018 at 8:08 am #2766363

nikiN

About the field "Available", it's supposed to have values of Yes, No and Hidden, when an entry is set to Hidden they shouldn't show on the front page. I set translation to "copy" to get the same values (Yes,No,Hidden) without translating them, but I could still see all the entries on the front page. How can I make sure they are hidden on the front page?

September 27, 2018 at 4:33 am #2769301

Ricardo Alday

I think it's a cache issue. I tested on a local copy and the Available value updates to the translation and hides the entry on the homepage. So it's working as expected. Deactivate any caching plugins and clear your browser cache as well.

September 27, 2018 at 8:38 am #2769807

nikiN

I activated the menu again and I see a lot of "extra" entries. When I go to the list of Escort and select English as the language I see many double entries that have no translation. When I click on them they don't show that they are translations of anything. For example Morgan has two entries, one with translations on all languages (and works normally) while the second one is only available in English. It shows as a translation but there is no Greek version of that so I can't edit the custom fields.

1) How did these "extra" entries appear? And how do I prevent it from happening in the future

2) How can I find and delete them all on all languages easily? Other than browsing through all of them and deleting those with only one language set.

September 27, 2018 at 5:09 pm #2771340

Ricardo Alday

1. I noticed that there were some duplicates but I thought you had created them. I'm not sure how that happened. I created a couple of Escort entries in Greek and they didn't show in the Escort list other languages, at least not until I translated them.

2. There isn't an easier way. You just have to browse through all of them in Escorts -> All Escorts -> All languages. The ones without translations will have + signs for all languages in the column with the flags.

September 27, 2018 at 5:35 pm #2771408

nikiN

No I did not create those. The main issue with the translations is that the website already had too many Escorts and I was using Polylang to translate them. Something must've gone wrong when porting over to WPML or when I was doing the translations.

I'll try deleting the extras and see if the main is fixed. Another question: is there a way to migrate from Advanced Custom Fields to Types/Views? Or I have to create everything from scratch?

September 27, 2018 at 9:20 pm #2771815

Ricardo Alday

Oh, I didn't know you had imported the Escorts posts from Polylang. That probably explains the double posts. Anyhow, after you manually clean them up I don't think you will have any issues.

Regarding migrating ACF to Types, unfortunately, we don't have an option to migrate the ACF fields but you can allow our Types plugin to control them.
https://toolset.com/faq/how-do-i-convert-existing-custom-types-and-fields-to-types-control/

Hope that helps.

September 28, 2018 at 11:20 am #2773495

nikiN

Because something happened during the transfer from Polylang to WPML, and the custom fields weren't transferred, is there a why to remove every single translation from the custom posts so I can re-translate them again? If it's not possible to remove all translations from custom posts without removing page translations that's fine too.

Otherwise I'd have to re-translate every custom post anyway to get the custom field values that do not currently exist on the translations

September 28, 2018 at 5:26 pm #2774514

Ricardo Alday

To remove the translated posts go to Escorts -> All Escorts, select one of the languages. Select all the posts in that language and delete them. Do the same for all secondary languages on the site.

September 30, 2018 at 9:47 am #2776376

nikiN

I deleted the extra translations. I don't know if it's normal but the custom posts don't have the "+" sign anymore, it's only visual I guess because I can open the translation and click "redeliver"

One other problem is with this plugin:
https://wordpress.org/plugins/email-subscribers/
It sends an email to all subscribers when I make a translation, I want only one email to be send (the first time I make a post) How can I do that?

October 1, 2018 at 5:18 pm #2778959

Ricardo Alday

1. Make sure you emptied the Escort post type trash. Once you do that you will see the + signs again.

2. Since your original issue is resolved now, may I kindly ask you to start a new thread about other issues you have? With the policy 1 issue = 1 ticket we are sure to provide the best and dedicated support, and the other clients with the same issue can easier find the solution.

Thanks.

October 2, 2018 at 7:04 am #2780519

nikiN

My issue is resolved now. Thank you!