This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 3 voices.

Last updated by chrisN-10 1 year, 3 months ago.

Assigned support staff: David.

Author Posts
June 8, 2018 at 3:04 pm #2400629

davev-7

I am trying to:

Select an editor

I expected to see:

Selecting the classic editor wont let me advance, the advance editor selection gives a not found error.

Updated all plugins to the latest version.

June 11, 2018 at 6:08 pm #2405954

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Can you update the plugins to latest releases and share access details?
I need to try selecting the advanced editor while inspecting the request in the browser.
I have marked your next reply as private.

June 12, 2018 at 3:53 pm #2408801

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

I would need you to try updating to the latest releases before anything else.
I just checked and there are 3 WPML plugins that need an update.

Let me know how it goes.

June 13, 2018 at 8:58 am #2410462

davev-7

Ok have been updated.

June 14, 2018 at 1:46 pm #2413618

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

The new TM wizard uses the JSON rest API to select the editor.
But the rest API is not working on your site.
Do you have any idea why?

June 15, 2018 at 9:29 am #2415130

davev-7

hidden link

It seems to be active. PHP 7.1 json also activated.

June 19, 2018 at 5:27 pm #2422674

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thats interesting, but the one that doesn't work is:
hidden link

Let me do some tests, I will get back to you.

June 19, 2018 at 5:38 pm #2422697

David
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Oh, I see! ... you have the folder enabled for the default language.

You need to create a root page in WPML -> Languages:

Can you try this and let me know how it goes?

June 20, 2018 at 10:12 am #2424141

davev-7

Hi David,

No luck on that one. I however switched the url format to parameter and after that wp-json worked in the root. I went through the setup and switched it back to directory url style.

Not a definitive fix but at least a good workaround.

Thanks for your time and help in this matter

October 4, 2018 at 3:29 pm #2787957

chrisN-10

I had the same problem: I also needed to activate SSL on the website for it to work.