Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Riffaz 2 weeks, 3 days ago.

Assigned support staff: Riffaz.

Author Posts
November 18, 2019 at 4:35 am #4961695

mark-gillU

Tell us what you are trying to do? to enable the Use WPML's Advanced Translation Editor"

Is there any documentation that you are following? none

Is there a similar example that we can see?

What is the link to your site?

November 18, 2019 at 5:29 am #4961803

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

if possible please select the classic Translation editor and finish the configuration

afterwards - Go to WPML -> Settings -> Change to 'Manual Translation' -> Save the changes -> Switch back to Advance Translation Editor -> Save changes.

- You should get the activation email and be able to use the Advance Translation Editor.

let me know if the TypeError continues please after these steps.

Regards,
Riffaz.

November 18, 2019 at 6:27 am #4961939

mark-gillU

Still error despite the classic selected.

What do you mean i will receive an email activation to use the Advance Translation Editor?
I already purchased and downloaded and installed the plugin already.

November 18, 2019 at 6:56 am #4962131

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Still error despite the classic selected.
- do you mean, you are seeing the same error when you activate the classic editor

What do you mean i will receive an email activation to use the Advance Translation Editor?
- you will receive an email upon a successful ATE activation.

Such issues might be related to the following as well:

- Server config not allowing proper communication with ATE (not very likely)
- Server-side cache (very likely)
- Special config in files that I did not have access to (somewhat likely):
-- wp-config.php
-- .htaccess

I would like you to disable your server-side cahce if activated and to see if the issue persists. Other wise please once connected to your site, connect to your server and rename the .htaccess-file. Then go to Settings -> Permalinks and simply click the save button. This task will create a new .htaccess-file.

Let me know how it goes.

Regards,

November 19, 2019 at 7:34 am #4968887

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I do not see WPML in your site now: hidden link
Did you remove it?

Regards,

November 25, 2019 at 7:45 am #5008671

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for the details.

I realized you were asking about the elements that you created using "CS Page Builder" : hidden link which you did not create in the test site for testing.

This builder does not use the shortcode.
So this won't be supported by WPML.
This user also has the same issue : https://wpml.org/forums/topic/translating-page-home-not-working-with-advanced-translation-editor/

The only option to translate them is enabling the manual translation.

1. go to any page > edit
2. set this to OFF : hidden link
3. in the pop up select 'all contents' : hidden link
4. save
5. now click on + sign you will get the page where you can create from the scratch.
6. create them using your builder and use your second language content.

You could ask this with your theme as well.
Also, we suggest you to let to know your theme support or author regarding WPML go global program : https://wpml.org/documentation/theme-compatibility/go-global-program/

Hopefully, this explains the issue and the workaround.

Regards,
Riffaz.