This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 1.83 hours from now. Thank you for your understanding.

This topic contains 9 replies, has 3 voices.

Last updated by Translate Media 4 weeks, 1 day ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
September 16, 2019 at 1:43 pm #4580911

Translate Media

I'm trying to send content for translation from WPML to TranslateMedia but it won't process the Portuguese:

This is the error:

Sending batch Healthy-Heart.org|WPML|en|2 to translation.
Batch #1

(3) This service does not support the following iso-codes: pt-pt

Rollback jobs...

Batch rolled back

I tried to delete the Portuguese language and add a custom language with pt as teh code but that just says:

The default locale already exists.

How can this be fixed?

September 17, 2019 at 10:30 am #4587685

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I spoke with our Translation Proxy team, and to fix the issue we should need your site's credentials.

I'll enable a private reply.

September 17, 2019 at 11:22 am #4587967

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for the credentials, I'll let you know if we need FTP but I don't think so.

September 17, 2019 at 3:43 pm #4589849

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

we checked the site and you should be able to add the pt language now. Probably it didn't let you because the old pt-pt language had the hreflang pt.

Let me know if this helps you or if you need further assistance.

September 17, 2019 at 3:45 pm #4589855

Translate Media

Thanks. Does this mean I need to add a custom language with the code "pt" or will adding Portuguese from the Languages page add the language with "pt" rather than "pt-pt"?

September 18, 2019 at 7:34 am #4593231

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

you should add a new language with the pt code.

September 18, 2019 at 10:21 am #4594993

Translate Media

I tried - still getting the same error.

September 19, 2019 at 8:30 am #4602571

Translate Media

Just wondering if this issue has been resolved yet. Because I can provide PHPMyAdmin access if that helps. It's fairly urgent so please let me know if it can be resolved soon.

September 19, 2019 at 10:41 am #4603717

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I have added the language "Português" with the language code "pt", check the attached screenshot.

Best regards.

September 19, 2019 at 10:45 am #4603749

Translate Media

My issue is resolved now. Thank you!