Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 5 replies, has 2 voices.

Last updated by Rohan Sadanandan 4 weeks, 1 day ago.

Assigned support staff: Rohan Sadanandan.

Author Posts
October 18, 2019 at 11:57 am #4781647

inakiM-5

Tell us what you are trying to do?

I am trying to set language url format and none of the options works. I am using Revolution Slider for the whole site with the WPML options. Rev Slider doesn't seem to be the problem, it will probably some setting on php settings or other I don't know about but don't really know to be honest.

All requirements for WPML are correct.

Is there any documentation that you are following?

Look for serveral cases and following solutions but I don't hit the right spot

What is the link to your site?

hidden link

October 18, 2019 at 3:41 pm #4784115

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

I don't get the exact issue. Could you please elaborate on the issue with a screenshot or URL so that I can understand better?

Thanks,
Rohan

October 18, 2019 at 4:00 pm #4784315

inakiM-5

Of course, so I want to see how my site would look in english (primary language is spanish) and I can't because none of the url formats seem to work. See screenshots.

The one that seems to give less problems is the last option (gives this url: hidden link) but when I browse it loads the wordpress theme I am using (Blank Slate) without any of the Revolution Sliders. The other options have warnings that directly warns that the urls for secondary language won't work. I don't care which option to choose but I have to make it work.

Thanks in advance

October 18, 2019 at 6:07 pm #4784835

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for sharing the details.

I can see that in your default language many of the images are missing.

Also, have you translated the Homepage & the Slider Revolution to the secondary language?
You can follow this documentation for translating Slider Revolution: https://wpml.org/documentation/plugins-compatibility/creating-multilingual-sliders-with-revolution-slider-and-wpml/

Thanks,
Rohan

October 19, 2019 at 5:49 am #4786741

inakiM-5

Please tell me images are missing only in the last slider at the bottom of the page. I see those missing after clearing cache on my browser (don't know why this happens as I checked links, even reuploaded and relinked images on slider but they are still missing). Anyways I will solve this with Revolution Slider support.

As of WPML I solved the problem. It wasn't a mistake on the configuration page or some php setting as I thought. Much simpler I just didn't know I had to set manually add the translation from the pages section in addition to having done it on slider revolution. Rookie mistake, sorry for that. Now all sliders I have translated appear translated, so its good.

I have noticed though that if I set automatic browser redirect to the language of the visitor, the http requests double hence lowering my GTmetrix and PageSpeed ranking by a lot. Doesn't happen if I don't activate it but I wonder if there is a way to keep this active and not doubling http requests?

October 21, 2019 at 1:29 pm #4794871

Rohan Sadanandan
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Sorry for the delay.

It's good to know that you have resolved the issue.

Regarding the automatic browser redirect, it is based on javascript. So both languages will load & js will be doing the redirection. That's why you can see that both the assets are loaded. So it is expected that the http requests will be doubled when you enable the same.

Thanks,
Rohan