Skip Navigation

This thread is resolved. Here is a description of the problem and solution.

Problem: I can't finish my WPML installation with Enfold theme.

Solution: - Follow the steps from the following Erratum.

Relevant Documentation: https://wpml.org/errata/enfold-theme-cannot-save-settings-language-switcher-options/

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Andrés 4 years, 3 months ago.

Assigned support staff: Andrés.

Author Posts
August 28, 2016 at 10:02 am #1025830

massimoS-6

Same problem as in my past ticket support.
I made a new installation of wpml and I cannot go past the language configuration. Last time you solved the problem but you did not tell me how you fixed it.
Is it a problem related to WP 4.6? Because I never encountered it before.

August 29, 2016 at 6:12 am #1026590

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Max,

Welcome again 🙂

I'm sorry but I don't find the ticket where we handle that issue. Maybe you can find it easily?

However, I think I understand your situation and it could be related to your theme Enfold. For that you can count on 2 solutions:

1. Please follow the steps and add the code as it is mentioned here:
https://wpml.org/errata/enfold-theme-cannot-save-settings-language-switcher-options/

OR:

2. Change temporary your theme to TwentySixteen.
- Finish the WPML wizard installation.
- Change again your theme to Enfold.

Does it help?

Best regards,
Andrés

August 29, 2016 at 12:37 pm #1027820

massimoS-6

Hi Andres,

I tried both way but nothing changed, it's as if the "continue" button was not active.
The old ticked was with Ankit and not with you, that's why you don't remember, my fault.
He wanted the admin username and password for the site then he fixed the problem (but did not tell me how). But yes, also the other site uses Enfold theme.

August 29, 2016 at 2:37 pm #1028214

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

I would like to request temporary access (wp-admin and FTP) to your test site to take a better look at the issue. Could you please indicate me how to replicate this behaviour?

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok for you.

*Important: Be sure to backup your site and database first before you proceed!
You can use a plugin for this if you like. You can use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Privacy and Security when Providing Debug Information for Support:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

August 30, 2016 at 7:17 am #1033600

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Hello Max,

This issue comes from a new setting introduced by Enfold. It sets a value of transparent for some colours that is not allow by WPML. The solution from the errata should have solved it, however, it didn't.

As a workaround, I changed those transparent colours from your Footer language switcher to white instead of transparent and the problem is solved.

Could you please verify it?

Regards,
Andrés

August 30, 2016 at 7:58 am #1033749

massimoS-6

Hi Andrés,

WPML is installed and the problem solved! Thanks!

Max

August 30, 2016 at 8:15 am #1034903

Andrés
Supporter

Languages: English (English ) Spanish (Español ) French (Français )

Timezone: Europe/Paris (GMT+01:00)

Awesome!
Have a nice day,
Andrés