This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by Andreas W. 4 months, 1 week ago.

Assigned support staff: Andreas W..

Author Posts
June 6, 2019 at 1:46 pm #3969647

thaddeusR

I just install plugin and active. the setup wpml steps. I can't go from Translation Language step. The next button disable forever. see hidden link and hidden link i notice lot of jQuery error. what we do?

June 6, 2019 at 9:29 pm #3972255

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

Some plugin or the theme is not able to load jQuery from your server.

Could you please switch to a default theme like Twenty Seventeen and deactivate anz plugin but WPML. Does the issue persist?

If yes, please deactivate and delete WPML and install a fresh download from here:
https://wpml.org/account/downloads/

If this will still not solve the issue ith only WPML activated, please get back to step one of the setup wizzard and try to set a different default language. Then get to step two and let me know if you were able to select the language now.

Further, could you please increase your PHP Memory Limit to 512m (php.ini) and the WP Memory limit to 256M (wp-config.php)? 128M is the minimum required by WPML.
Your current values are:

MemoryLimit 256M
WP Memory Limit 40M
Add this code to your wp-config.php to increase WP memory:

/* Memory Limit /
define('WP_MEMORY_LIMIT', '256M');

Paste it just before:

/ That's all, stop editing! Happy blogging. /

These settings can be limited directly by your hosting provider, so I recommend you to contact and ask them to modify them directly.
If you can get even higher values It would be great.

https://wpml.org/home/minimum-requirements/
Note: WPML needs a minimum WP Memory limit of 128M to work only under a minimal environment, it means, with a default theme and not other plugins installed.

Please also change the value of "maxInputVars" inside of your php.ini file. You are currently using a value of 1000. I would recommend you to change this setting to at least 3000.
You can find the php.ini file on your server inside the folder for your currently used PHP version 7.2.19.

I would further suggest to update mySQL, as you are currently running version 5.5.5 whiel version 5.6 or higher is minimum requierment to run WPML.

In case of any doubt please contact your hosting provides and ask for assistance.

Kind regards
Andreas

June 7, 2019 at 5:52 am #3974107

thaddeusR

I just deactivate all plugins and switch wp default theme.
Reinstall wpml plugin.
increase php value you mention.
still not work. I'm unable to increase php and mysql version right now. you think that is the reason ?

June 7, 2019 at 5:07 pm #3978123

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

June 10, 2019 at 10:49 pm #3990709

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing you to let you know that I am taking a copz of your website for further investigation. I will further consult our second tier support once I obtained the copy.

The issue seems to appear even when all plugins are disabled and the theme is changed to a default theme. This is not a compatibility issue as the issue does not appear on a new WordPress installtion. It might be that the problem occurs due to custom coding on your site.

Did you take any further changes than inside of the wp-config.php? I can see you will run a Multisite? Is this correct?

Kind regards
Andreas

June 11, 2019 at 7:44 am #3992883

thaddeusR

Haven't multisite. Just single site. I only increase WP Memory limit to wp-config.php file. It should work after deactivate all plugins and switch theme. but it doesn't? custom code only apply on theme.

June 11, 2019 at 5:20 pm #3997661

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

It seems there are more customizations in wp-config.php or other files of WordPress Core.

For example, I was asking about the Multisite as the wp-config.php says:

define( 'WP_ALLOW_MULTISITE', true );

Also, the issue is not appearing on a new installation of WordPress. I even tried to disable all plugins and changed to a default theme on zour site and the issue persists.

I would adivse you to setup a new WordPress installtion. For already generated users and content please use the WordPress Export/Import features.
hidden link

Let me know if this solved the issue.

Kind regards
Andreas