This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 3 voices.

Last updated by laurenceC-6 5 months ago.

Assigned support staff: Alejandro.

Author Posts
May 9, 2019 at 12:23 pm #3776093

laurenceC-6

I am trying to:
Translate a page by clicking the + symbol and entering the new text, then clicking Save

Link to a page where the issue can be seen:
Its backend not front

I expected to see:
The translated page, with a pencil icon

Instead, I got:
No translated page when changing to that language, and a gears icon showing

May 9, 2019 at 12:31 pm #3776131

laurenceC-6

On the page is hundreds of media items to translate so I did not want to check all those boxes. But if it was due to this, not being completed, then I used this JS to check all boxes "$('.js-field-translation-complete').attr('checked', 'checked')" and it now says 100% Complete, but it still shows the gears, and the language still does not show this page (shows 0 pages).

So how do I get this to be an actual page in the other language? It used to work fine, has WPML changed a feature and made it harder?

Thanks

May 9, 2019 at 12:32 pm #3776133

laurenceC-6

What we need is like it used to be....
1) Click + sign
2) Enter text or copy from original
3) Save
4) Page now exists in other language

What we do not want is to have to check all these checkboxes to mark complete, and to have any other steps to make the page in the other language.

May 9, 2019 at 1:21 pm #3776461

laurenceC-6

Your documentation page explains the gears as this:
The content is translated, but the translation needs updating, and a new translation is already in progress -> Further action is not possible because a translation is already in progress

How is this applicable to me? What does it mean a new translation is already in progress? There is only one page I clicked to edit then save, there should be no other translations for this page. And then how do I stop this "new translation" in progress so it uses my actual translation I did?

May 9, 2019 at 2:51 pm #3777417

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi

1. Do you mind if I take a look directly on your site for this particular case?
Please provide login details and a link to the sample case in your next reply.

2. Have you tried increasing the PHP memory allocation in your wp-config.php file?

3. Please also try to complete the update when temporarily changing the active theme to Twenty Nineteen and with all non-WPML plugins deactivated.

THanks

May 14, 2019 at 6:20 am #3803957

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello, my name is Alejandro,

Since Yvette is currently not available, I will replace her here in the forum.

I hope this is OK with you.

I tried to access your site but it gives me an error, can you check if it happens with you too? if it doesn't then please check if by any chance your server has a firewall or something similar that might be blocking my access.

I'll leave you my IP in a private reply, in case it's needed for you to unblock me (if that's the case, of course).

Regards.

May 22, 2019 at 3:42 pm #3867255

laurenceC-6

Hi Alejandro
What error did you get please? It works Ok for me.
We use iThemes security but your IP or username is not in the blocklist.
Thanks
Laurence

May 22, 2019 at 4:02 pm #3867937

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

I get a "too many redirects" error, whenever i try to access the link that you gave me before (which i will send in a private reply).

May 23, 2019 at 10:25 am #3873615

laurenceC-6

Strange, works fine for us and the customer. Maybe clear all your cache? It does redirect to the following domain, I have replaced certain parts of the URL as I cant just choose to send you a private message. Would save a lot of time if I could!

hidden link

replace the domain with the original, and then the secret key is the same as in the original URL.

May 23, 2019 at 3:16 pm #3877389

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

It seems that your server was blocking me because i wasn't from the UK, but i overcame that restriction with a VPN.

I checked your site and also checked several pages that had the gear icon, but none of them were 100% completed. woudl you mind telling me the name of the page you mention in the first reply so i can have a reference page?

Thanks.

May 24, 2019 at 9:27 am #3882951

laurenceC-6

Ah thats our GEO redirect to other WPML sites, sorry I did not think of that for the Admin.

It was the page called "Home". BUT.... the cog has gone now. The way the customer manages it is go into the En page itself, then click the edit on the right for the language, and then that works OK. It was when you clicked the + to create the page in the main listing we had the issue.

So the customer has now created it OK using their method, and has not reported this issue.

So I dont think you should go in and start experimenting as its the live site and is now working OK, so we dont want anything changed.

So I think we should close this for now, and if it happens again and is an issue for the customer I will re-open it and send access to a dev site we have.

Thanks for your help, and sorry for the trouble logging in.

May 24, 2019 at 9:27 am #3882953

laurenceC-6

I will close/resolve this ticket for now